summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-devtools
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-devtools')
-rw-r--r--meta-phosphor/recipes-devtools/i2c-tools/i2c-tools_%.bbappend1
-rw-r--r--meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb10
-rw-r--r--meta-phosphor/recipes-devtools/perl/yaml-tiny_1.73.bb13
-rw-r--r--meta-phosphor/recipes-devtools/python/pyphosphor_git.bb34
-rw-r--r--meta-phosphor/recipes-devtools/python/python3_%.bbappend9
-rw-r--r--meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend7
6 files changed, 35 insertions, 39 deletions
diff --git a/meta-phosphor/recipes-devtools/i2c-tools/i2c-tools_%.bbappend b/meta-phosphor/recipes-devtools/i2c-tools/i2c-tools_%.bbappend
index fefe06252d..be6409f527 100644
--- a/meta-phosphor/recipes-devtools/i2c-tools/i2c-tools_%.bbappend
+++ b/meta-phosphor/recipes-devtools/i2c-tools/i2c-tools_%.bbappend
@@ -1,2 +1,3 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
SRC_URI =+ "file://0001-4-byte-read-support-466.patch"
diff --git a/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb b/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb
index 54303fa0bd..c0c76ce1bd 100644
--- a/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb
+++ b/meta-phosphor/recipes-devtools/iotools/iotools_1.6.bb
@@ -3,19 +3,19 @@ HOMEPAGE = "https://github.com/jonmayergoogle/iotools"
LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SRCREV = "8d928b3360246b8ead95b442ca3887ce8b8f942f"
-SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https;branch=master"
PV = "v1.6+git${SRCPV}"
-inherit obmc-phosphor-systemd
+SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
-FILES:${PN} = "${sbindir}"
+SYSTEMD_SERVICE:${PN} += "iotools-setup.service"
+
+inherit obmc-phosphor-systemd
do_compile() {
# CC is overridden in the Makefile, so override it harder in the invocation
oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0
}
-
# The "install" make target runs the binary to create links for subcommands.
# The links are excessive and this doesn't work for cross compiling.
do_install() {
@@ -23,4 +23,4 @@ do_install() {
install -m 0755 iotools ${D}${sbindir}
}
-SYSTEMD_SERVICE:${PN} += "iotools-setup.service"
+FILES:${PN} = "${sbindir}"
diff --git a/meta-phosphor/recipes-devtools/perl/yaml-tiny_1.73.bb b/meta-phosphor/recipes-devtools/perl/yaml-tiny_1.73.bb
index 845242b4f6..a8a15c6597 100644
--- a/meta-phosphor/recipes-devtools/perl/yaml-tiny_1.73.bb
+++ b/meta-phosphor/recipes-devtools/perl/yaml-tiny_1.73.bb
@@ -1,20 +1,17 @@
SUMMARY = "YAML::Tiny Version 1.73"
-PR = "r1"
-LICENSE = "Artistic-1.0 | GPL-1.0+"
HOMEPAGE = "https://metacpan.org/release/YAML-Tiny"
-
-inherit cpan
-inherit allarch
-
+LICENSE = "Artistic-1.0 | GPL-1.0+"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
file://${COMMON_LICENSE_DIR}/GPL-1.0-or-later;md5=30c0b8a5048cc2f4be5ff15ef0d8cf61"
-
+PR = "r1"
SRC_URI += "https://cpan.metacpan.org/authors/id/E/ET/ETHER/YAML-Tiny-1.73.tar.gz"
-
SRC_URI[md5sum] = "d1bb2525e4ab46bfab4b22842c467529"
SRC_URI[sha256sum] = "bc315fa12e8f1e3ee5e2f430d90b708a5dc7e47c867dba8dce3a6b8fbe257744"
S = "${WORKDIR}/YAML-Tiny-${PV}"
+inherit cpan
+inherit allarch
+
BBCLASSEXTEND = "native"
diff --git a/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb b/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
index c2cfdb4cb9..039c718de2 100644
--- a/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
+++ b/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
@@ -1,25 +1,20 @@
SUMMARY = "Phosphor python library"
DESCRIPTION = "Phosphor python library."
HOMEPAGE = "http://github.com/openbmc/pyphosphor"
-PR = "r1"
-PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+SRCREV = "cb240aa1ed95799d2ea8bde951c6ed443839a7e0"
+PV = "1.0+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "git://github.com/openbmc/pyphosphor;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
inherit allarch
inherit setuptools3
inherit python3-dir
-PACKAGE_BEFORE_PN = " \
- ${PN}-ns \
- ${PN}-utils-ns \
- ${PN}-dbus-ns \
- ${PN}-wsgi-ns \
- ${PN}-wsgi-apps-ns \
- ${PN}-utils \
- ${PN}-dbus \
- "
-
RDEPENDS:${PN}-utils-ns += "${PN}-ns"
RDEPENDS:${PN}-dbus-ns += "${PN}-ns"
RDEPENDS:${PN}-utils += "${PN}-utils-ns"
@@ -44,12 +39,15 @@ FILES:${PN}-utils-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/utils/__init__.py*"
FILES:${PN}-dbus-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/dbuslib/__init__.py*"
FILES:${PN}-wsgi-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/wsgi/__init__.py*"
FILES:${PN}-wsgi-apps-ns = "${PYTHON_SITEPACKAGES_DIR}/obmc/wsgi/apps/__init__.py*"
-
FILES:${PN}-utils = "${PYTHON_SITEPACKAGES_DIR}/obmc/utils"
FILES:${PN}-dbus = "${PYTHON_SITEPACKAGES_DIR}/obmc/dbuslib"
-SRC_URI += "git://github.com/openbmc/pyphosphor;branch=master;protocol=https"
-
-SRCREV = "cb240aa1ed95799d2ea8bde951c6ed443839a7e0"
-
-S = "${WORKDIR}/git"
+PACKAGE_BEFORE_PN = " \
+ ${PN}-ns \
+ ${PN}-utils-ns \
+ ${PN}-dbus-ns \
+ ${PN}-wsgi-ns \
+ ${PN}-wsgi-apps-ns \
+ ${PN}-utils \
+ ${PN}-dbus \
+ "
diff --git a/meta-phosphor/recipes-devtools/python/python3_%.bbappend b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
index a2dafcf6c3..c3de5a05f2 100644
--- a/meta-phosphor/recipes-devtools/python/python3_%.bbappend
+++ b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
@@ -1,9 +1,5 @@
inherit update-alternatives
-ALTERNATIVE:${PN}-core += "python"
-ALTERNATIVE_LINK_NAME[python] = "${bindir}/python"
-ALTERNATIVE_TARGET[python] = "${bindir}/python3"
-
# python3 takes up a lot of space that most embedded systems
# do not have, so remove some un-needed files from the rootfs
do_install:append:class-target() {
@@ -11,3 +7,8 @@ do_install:append:class-target() {
# a large, compressed version of pip. Remove it to free up the space.
rm -rf ${D}${libdir}/python${PYTHON_MAJMIN}/ensurepip
}
+
+ALTERNATIVE_LINK_NAME[python] = "${bindir}/python"
+
+ALTERNATIVE:${PN}-core += "python"
+ALTERNATIVE_TARGET[python] = "${bindir}/python3"
diff --git a/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend b/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend
index 8502a0af13..6a235b6068 100644
--- a/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend
+++ b/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend
@@ -1,8 +1,7 @@
+DEPENDS:append:class-target = " popt zlib"
+PACKAGECONFIG = ""
+
EXTRA_OECONF:append:class-target = " \
--disable-locale --disable-iconv \
--without-included-popt --without-included-zlib \
"
-
-PACKAGECONFIG = ""
-
-DEPENDS:append:class-target = " popt zlib"