summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb')
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb19
1 files changed, 9 insertions, 10 deletions
diff --git a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
index d0443d1ce6..f682b62c95 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
@@ -1,12 +1,5 @@
SUMMARY = "sdbus++ dbus API / binding generator"
DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
-
-PYPI_PACKAGE = "sdbusplus"
-PV = "1.0"
-inherit setuptools3
-
-include sdbusplus-rev.inc
-
## The sdbusplus repository has an Apache LICENSE file, which we would
## normally check here, but the python setup script is in a subdirectory
## which requires us to set ${S} below. When we change ${S} from the root
@@ -14,14 +7,18 @@ include sdbusplus-rev.inc
## to the common Apache license file in poky's meta instead.
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-S="${WORKDIR}/git/tools"
-
DEPENDS += " \
${PYTHON_PN}-inflection-native \
${PYTHON_PN}-mako-native \
${PYTHON_PN}-pyyaml-native \
"
+PV = "1.0"
+
+PYPI_PACKAGE = "sdbusplus"
+
+S = "${WORKDIR}/git/tools"
+
+inherit setuptools3
RDEPENDS:${PN} += " \
${PYTHON_PN}-inflection \
@@ -29,4 +26,6 @@ RDEPENDS:${PN} += " \
${PYTHON_PN}-pyyaml \
"
+include sdbusplus-rev.inc
+
BBCLASSEXTEND += "native nativesdk"