summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
diff options
context:
space:
mode:
authorPatrick Venture <venture@google.com>2018-10-06 01:08:31 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-08 04:03:56 +0300
commit3720a742e6345e2cbef6eb351cf4b2a4e9050830 (patch)
tree8595655848635737db5ca0dd0ffe4f1a1b0961db /meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
parent08b61b6edaabc4eb87f437d85b0fae2efdbe2509 (diff)
downloadopenbmc-3720a742e6345e2cbef6eb351cf4b2a4e9050830.tar.xz
meta-phosphor: mapper: rename as git
Rename phosphor-mapper.bb to phosphor-mapper_git.bb per OE norms. (From meta-phosphor rev: 90b2a3f8b17696486bc54cec83f2d09a33048da5) Change-Id: I66238f2ffc77efa7b362fe0ea4f07f3e65f5c1c7 Signed-off-by: Patrick Venture <venture@google.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb99
1 files changed, 99 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
new file mode 100644
index 0000000000..159b04cbc1
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
@@ -0,0 +1,99 @@
+SUMMARY = "Phosphor DBUS Object Manager"
+DESCRIPTION = "Phosphor DBUS object manager."
+HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-python-autotools
+inherit obmc-phosphor-dbus-service
+inherit obmc-phosphor-systemd
+inherit phosphor-mapperdir
+
+DEPENDS += "systemd"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "boost"
+DEPENDS += "libtinyxml2"
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-logging"
+DEPENDS += "${PN}-config-native"
+
+DBUS_SERVICE_${PN} += "xyz.openbmc_project.ObjectMapper.service"
+SYSTEMD_SERVICE_${PN} += " \
+ mapper-wait@.service \
+ mapper-subtree-remove@.service \
+ "
+RDEPENDS_libmapper += "libsystemd"
+RDEPENDS_${PN} += " \
+ python-argparse \
+ python-xml \
+ python-dbus \
+ python-pygobject \
+ pyphosphor-dbus \
+ pyphosphor-utils \
+ sdbusplus \
+ phosphor-logging \
+ "
+SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
+
+SRCREV = "a493615230bd5e00d8bc5345f556a884448540cb"
+
+S = "${WORKDIR}/git"
+
+python populate_packages_prepend () {
+ mapperlibdir = d.getVar("libdir", True)
+ do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
+}
+PACKAGES_DYNAMIC += "^libmapper.*"
+FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"
+
+# Construct a systemd environment file with mapper commandline
+# from the native sysroot /usr/share/phosphor-mapper filesystem.
+python do_emit_env() {
+ path = d.getVar('STAGING_DIR_NATIVE', True) + \
+ d.getVar('namespace_dir', True)
+ paths = []
+ for p in os.listdir(path):
+ paths.append(os.sep.join(p.split('-')))
+
+ path = d.getVar('STAGING_DIR_NATIVE', True) + \
+ d.getVar('interface_dir', True)
+ interfaces = []
+ for i in os.listdir(path):
+ interfaces.append('.'.join(i.split('-')))
+
+ path = d.getVar('STAGING_DIR_NATIVE', True) + \
+ d.getVar('blacklist_dir', True)
+ blacklists = []
+ for b in os.listdir(path):
+ blacklists.append(os.sep + os.sep.join(b.split('-')))
+
+ path = d.getVar('STAGING_DIR_NATIVE', True) + \
+ d.getVar('interfaceblacklist_dir', True)
+ interface_blacklists = []
+ for ib in os.listdir(path):
+ interface_blacklists.append('.'.join(ib.split('-')))
+
+ path = [d.getVar('D', True) + d.getVar('envfiledir', True)]
+ path.append('obmc')
+ path.append('mapper')
+ parent = os.path.join(*path[:-1])
+ path = os.path.join(*path)
+
+ if not os.path.exists(parent):
+ os.makedirs(parent)
+ with open(path, 'w+') as fd:
+ fd.write('MAPPER_NAMESPACES="{}"'.format(' '.join(paths)))
+ fd.write('\n')
+ fd.write('MAPPER_INTERFACES="{}"'.format(' '.join(interfaces)))
+ fd.write('\n')
+ fd.write('MAPPER_BLACKLISTS="{}"'.format(' '.join(blacklists)))
+ fd.write('\n')
+ fd.write('MAPPER_INTERFACEBLACKLISTS="{}"'.format(' '.join(interface_blacklists)))
+ fd.write('\n')
+}
+
+do_install[postfuncs] += "do_emit_env"
+do_install[vardeps] += "PHOSPHOR_MAPPER_NAMESPACES"