summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-09-09 00:51:14 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-13 18:05:54 +0300
commit56d3704d6ea0f593e5272b71e029805fb90de495 (patch)
treed85d6a243a14c04b3ecfa0626022aec7e7d219c6 /meta-phosphor/recipes-phosphor/dbus
parent4e89e85e4eeddbb808e3e2310e0b26103c005ce9 (diff)
downloadopenbmc-56d3704d6ea0f593e5272b71e029805fb90de495.tar.xz
phosphor-dbus-interfaces: switch to meson
Switch recipe to use the meson build flow. For some machines there is a .bbappend with an EXTRA_OECONF to enable PDI YAML subtrees. This has been made redundant by the move to meson and a small amount of processing on OBMC_ORG_YAML_SUBDIRS in the recipe. The scattered .bbappend files can be removed once this commit is merged. (From meta-phosphor rev: 7e63969760ebd0fed5f76e249203873c2f56f36c) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I044b8547965889bd1090861c87303b5559e925c1 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb16
1 files changed, 13 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 658843ba6a..835abaf283 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -6,16 +6,26 @@ S = "${WORKDIR}/git"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit autotools pkgconfig
-inherit python3native
+inherit meson
+inherit obmc-phosphor-utils
inherit phosphor-dbus-yaml
+inherit python3native
DEPENDS += " \
${PYTHON_PN}-sdbus++-native \
- autoconf-archive-native \
sdbusplus \
systemd \
"
SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces"
SRCREV = "11699d678d4166ff4b23900f31794754f305df64"
+
+# Process OBMC_ORG_YAML_SUBDIRS to create Meson config options.
+# ex. xyz/openbmc_project -> -Ddata_xyz_openbmc_project=true
+def pdi_meson_config(d):
+ return ' '.join([
+ '-Ddata_' + x.replace('/', '_') + '=true' \
+ for x in listvar_to_list(d, 'OBMC_ORG_YAML_SUBDIRS')
+ ])
+
+EXTRA_OEMESON_append = " ${@pdi_meson_config(d)}"