summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-09-15 18:33:02 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-15 22:49:48 +0300
commitbec9f783372331e3bdc41a944f957e2d16888708 (patch)
treedb0a0a0eeb1093ea0f78bc4778b61718d9c56123 /meta-phosphor/recipes-phosphor/dbus
parentc6ffea910c44373dc8278429b10c2348bc722a2a (diff)
downloadopenbmc-bec9f783372331e3bdc41a944f957e2d16888708.tar.xz
phosphor-dbus-interfaces: add sstate hint for pdi_meson_config
We were seeing intermittent CI failures where the header files do not include `org.open_power` when building openpower machines. I suspect this is due to incorrect sstate hints causing an openpower machine to use header files generated from an x86 machine. To fix this add a 'vardep' hint to the 'pdi_meson_config' function, which is used to formulate the EXTRA_OEMESON config flags to meson. Looking at `bitbake-dumpsig` output before change: List of dependencies for variable EXTRA_OEMESON is {'PACKAGECONFIG_CONFARGS', 'pdi_meson_config'} List of dependencies for variable pdi_meson_config is {'listvar_to_list'} After change: List of dependencies for variable EXTRA_OEMESON is {'pdi_meson_config', 'PACKAGECONFIG_CONFARGS'} List of dependencies for variable pdi_meson_config is {'OBMC_ORG_YAML_SUBDIRS', 'listvar_to_list'} OBMC_ORG_YAML_SUBDIRS has now been added to the variable dependency for the sstate hash calculation, which is where the needed interfaces are defined. (From meta-phosphor rev: f48f5ba3d0e6bf075bce9cd5650ceeb205e25543) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Id3ec1cd776e7d8f08d2934cc4981a93d14bd907e Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 835abaf283..cb7c64bf76 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -27,5 +27,6 @@ def pdi_meson_config(d):
'-Ddata_' + x.replace('/', '_') + '=true' \
for x in listvar_to_list(d, 'OBMC_ORG_YAML_SUBDIRS')
])
+pdi_meson_config[vardeps] = "OBMC_ORG_YAML_SUBDIRS"
EXTRA_OEMESON_append = " ${@pdi_meson_config(d)}"