summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-01-14 01:22:54 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-01-14 04:42:22 +0300
commitd5ed092177c950521a860f9c3f5d5294be0678ea (patch)
treefbef8562cf2812fe60bca0498429196239dac8dd /meta-phosphor/recipes-phosphor/dbus
parentb9e124c6a51c8a9859a2257bc9205382fc7a010e (diff)
downloadopenbmc-d5ed092177c950521a860f9c3f5d5294be0678ea.tar.xz
meta-phosphor: phosphor-dbus-interfaces: add explicit task-dep on unpack
The recipe has an extension to the `do_write_config` task that forces all of the YAML subdirectory options to `false` using the list in the `meson_options.txt`. Since we are parsing the `meson_options.txt`, we need it to be present, so we need to explicitly rely on the `do_unpack` task. Tested: The `log.task_order` has the correct order. ``` $ cat log.task_order 20230113-151838.797418 do_fetch (3200585): log.do_fetch.3200585 20230113-151840.771096 do_unpack (3201820): log.do_unpack.3201820 20230113-151842.762491 do_write_config (3202881): log.do_write_config.3202881 ``` Ran `bitbake phosphor-dbus-interfaces -ne` and examined the `taskdeps` structure to confirm the dependency is added. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I0d81d127fd1bda39eeb38e6ce89614e1f4ddfa30
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 6962469221..4dbc470d37 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -39,3 +39,4 @@ do_write_config:append() {
sed -i "/^\[built-in options\]\$/a$intf = false" ${WORKDIR}/meson.cross
done
}
+do_write_config[deptask] += "do_unpack"