summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2024-02-18 01:06:52 +0300
committerPatrick Williams <patrick@stwcx.xyz>2024-02-20 21:43:57 +0300
commit0e1c5bb68e346cf38ae6b61b951a8fa6944efd62 (patch)
tree5af313126c42e32d6fad01f45ee0e72b940806a1 /meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
parent1b994ec0fda2f7032fe09d38ff6450917473dec4 (diff)
downloadopenbmc-0e1c5bb68e346cf38ae6b61b951a8fa6944efd62.tar.xz
phosphor-fan: fix sensor-monitor packaging
The phosphor-fan recipe was defining two different subpackages: - phosphor-fan-sensor-monitor - containing systemd service - sensor-monitor - containing the executable As a result you could end up with a situation where only the systemd services are installed (if you RDEPEND on phosphor-fan-sensor-monitor) without the corresponding executable. Adjust the packaging to only have the phosphor-fan-sensor-monitor. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ia4061fce582d1a7e3eb3630489a6693d907f8617
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
index d9fbf418a1..346b58343e 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan_git.bb
@@ -90,8 +90,8 @@ SYSTEMD_LINK:${PN}-monitor += "${@bb.utils.contains('PACKAGECONFIG', 'json', \
SYSTEMD_LINK:${PN}-monitor += "${@bb.utils.contains('PACKAGECONFIG', 'json', \
compose_list(d, 'FMT_MONITOR_MUSR', 'OBMC_CHASSIS_ZERO_ONLY'), \
compose_list(d, 'FMT_MONITOR_INIT', 'OBMC_CHASSIS_ZERO_ONLY'), d)}"
-SYSTEMD_SERVICE:sensor-monitor += "sensor-monitor.service"
-SYSTEMD_LINK:sensor-monitor += "../sensor-monitor.service:${MULTI_USR_TGT}.wants/sensor-monitor.service"
+SYSTEMD_SERVICE:${PN}-sensor-monitor += "sensor-monitor.service"
+SYSTEMD_LINK:${PN}-sensor-monitor += "../sensor-monitor.service:${MULTI_USR_TGT}.wants/sensor-monitor.service"
inherit meson pkgconfig python3native
inherit obmc-phosphor-systemd
@@ -114,7 +114,7 @@ FILES:${PN}-monitor = "${bindir}/phosphor-fan-monitor"
# Package the JSON config files installed from the repo
FILES:${PN}-monitor += "${@bb.utils.contains('PACKAGECONFIG', 'json', \
'${datadir}/phosphor-fan-presence/monitor/*', '', d)}"
-FILES:sensor-monitor += " ${bindir}/sensor-monitor"
+FILES:${PN}-sensor-monitor += " ${bindir}/sensor-monitor"
require ${BPN}.inc
@@ -153,4 +153,3 @@ FMT_MONITOR_MUSR = "../${TMPL_MONITOR}:${MULTI_USR_TGT}.wants/${INSTFMT_MONITOR}
TMPL_MONITOR_INIT = "phosphor-fan-monitor-init@.service"
INSTFMT_MONITOR_INIT = "phosphor-fan-monitor-init@{0}.service"
FMT_MONITOR_INIT = "../${TMPL_MONITOR_INIT}:${POWERON_TGT}.wants/${INSTFMT_MONITOR_INIT}"
-FAN_PACKAGES:append = "${@bb.utils.contains('PACKAGECONFIG', 'sensor-monitor', ' sensor-monitor', '', d)}"