summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/host
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:25:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 14:44:12 +0300
commitff075f6ee795a590b244d70a90cc312ba1f2d83d (patch)
treea617790bdbfdeef960665ba0242e1f0c93e5301a /meta-phosphor/recipes-phosphor/host
parent3e4da38c127bb7e7641adc2fc41f4c33744cb918 (diff)
downloadopenbmc-ff075f6ee795a590b244d70a90cc312ba1f2d83d.tar.xz
meta-phosphor: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-phosphor is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-phosphor rev: 471cfcefa74b8c7ceb704cb670e6d915cf27c63b) Change-Id: I3f106b2f6cdc6cec734be28a6090800546f362eb Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor/host')
-rw-r--r--meta-phosphor/recipes-phosphor/host/obmc-op-control-host.bb25
-rw-r--r--meta-phosphor/recipes-phosphor/host/obmc-op-control-host/op-start-host@.service21
-rw-r--r--meta-phosphor/recipes-phosphor/host/obmc-op-control-host/org.openbmc.control.Host@.service14
-rw-r--r--meta-phosphor/recipes-phosphor/host/phosphor-host-postd.bb26
-rw-r--r--meta-phosphor/recipes-phosphor/host/phosphor-host-postd.inc6
-rw-r--r--meta-phosphor/recipes-phosphor/host/phosphor-host-postd/lpcsnoop.service10
6 files changed, 102 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host.bb b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host.bb
new file mode 100644
index 0000000000..627f75956d
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host.bb
@@ -0,0 +1,25 @@
+SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER"
+DESCRIPTION = "A host control implementation suitable for OpenPOWER systems."
+PR = "r1"
+
+inherit skeleton-gdbus
+inherit obmc-phosphor-dbus-service
+inherit pkgconfig
+
+PROVIDES += "virtual/obmc-host-ctl"
+RPROVIDES_${PN} += "virtual-obmc-host-ctl"
+
+SKELETON_DIR = "op-hostctl"
+
+FMT = "org.openbmc.control.Host@{0}.service"
+DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_SERVICE_${PN} = " \
+ op-start-host@.service \
+ "
+
+START_TMPL = "op-start-host@.service"
+START_TGTFMT = "obmc-host-startmin@{1}.target"
+START_INSTFMT = "op-start-host@{0}.service"
+START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
+
+SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host/op-start-host@.service b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host/op-start-host@.service
new file mode 100644
index 0000000000..8703a4301f
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host/op-start-host@.service
@@ -0,0 +1,21 @@
+[Unit]
+Description=Start Host%i
+After=obmc-host-start-pre@%i.target
+Wants=obmc-host-starting@%i.target
+Before=obmc-host-starting@%i.target
+Before=obmc-host-started@%i.target
+Wants=obmc-power-on@%i.target
+After=obmc-power-on@%i.target
+Wants=mapper-wait@-org-openbmc-control-host%i.service
+After=mapper-wait@-org-openbmc-control-host%i.service
+Conflicts=obmc-host-stop@%i.target
+ConditionPathExists=!/run/openbmc/host@%i-on
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=/bin/sh -c "busctl call `mapper get-service /org/openbmc/control/host%i` /org/openbmc/control/host%i org.openbmc.control.Host boot"
+SyslogIdentifier=op-start-host
+
+[Install]
+WantedBy=obmc-host-start@%i.target
diff --git a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host/org.openbmc.control.Host@.service b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host/org.openbmc.control.Host@.service
new file mode 100644
index 0000000000..9a64002ec4
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host/org.openbmc.control.Host@.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=OpenPOWER Host%i Control
+Wants=mapper-wait@-org-openbmc-managers-System.service
+After=mapper-wait@-org-openbmc-managers-System.service
+
+[Service]
+Restart=always
+ExecStart=/usr/bin/env control_host.exe
+SyslogIdentifier=control_host.exe
+Type=dbus
+BusName={BUSNAME}
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd.bb b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd.bb
new file mode 100644
index 0000000000..92ff4890e3
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Phosphor OpenBMC Post Code Daemon"
+DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
+PR = "r1"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-systemd
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "systemd"
+
+RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
+
+SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
+POST_CODE_BYTES ?= "1"
+
+SERVICE_FILE = "lpcsnoop.service"
+SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
+SYSTEMD_SUBSTITUTIONS += "SNOOP_DEVICE:${SNOOP_DEVICE}:${SERVICE_FILE}"
+SYSTEMD_SUBSTITUTIONS += "POST_CODE_BYTES:${POST_CODE_BYTES}:${SERVICE_FILE}"
+
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+
diff --git a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd.inc b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd.inc
new file mode 100644
index 0000000000..8148950369
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd.inc
@@ -0,0 +1,6 @@
+HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+SRC_URI += "git://github.com/openbmc/phosphor-host-postd"
+SRCREV = "c820155fa71090122c7c0838900823570d073dfb"
+
diff --git a/meta-phosphor/recipes-phosphor/host/phosphor-host-postd/lpcsnoop.service b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd/lpcsnoop.service
new file mode 100644
index 0000000000..117702c04b
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/host/phosphor-host-postd/lpcsnoop.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=LPC Snoop Daemon
+After=systemd-modules-load.service
+
+[Service]
+Restart=always
+ExecStart={sbindir}/snoopd -d "/dev/{SNOOP_DEVICE}" -b "{POST_CODE_BYTES}"
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}