summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/interfaces
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2021-04-02 02:09:06 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-04-06 16:55:33 +0300
commitd7afac725243c9d6f091c774ef68263a3b4e8d5d (patch)
tree2a7b0168a97c28cac75737c811ea0924b332a81d /meta-phosphor/recipes-phosphor/interfaces
parent67fed83348e6e6fbd5a08ea57fe885bd3c51bf99 (diff)
downloadopenbmc-d7afac725243c9d6f091c774ef68263a3b4e8d5d.tar.xz
Fix issue with B variable in bmcweb
When bmcweb is built with devtool, the B directory includes the trailing slash, when it isn't devtooled (ie built normally) the B variable doesn't include the slash. This causes issues when enabling the bmcweb ptest targets. This commit adds the slash, to make it build in both cases Tested: built with: DISTRO_FEATURES_append = " ptest" CORE_IMAGE_EXTRA_INSTALL += "bmcweb-ptest" in local.conf, with both: devtool modify bmcweb and devtool reset bmcweb and verified code now builds both ways. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: Ie8bbe598b3d165f038c1e4df09ca97e02aeb539a
Diffstat (limited to 'meta-phosphor/recipes-phosphor/interfaces')
-rw-r--r--meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
index b26cec038c..67378cfed8 100644
--- a/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
+++ b/meta-phosphor/recipes-phosphor/interfaces/bmcweb_git.bb
@@ -44,7 +44,7 @@ RDEPENDS_${PN} += " \
do_install_ptest() {
install -d ${D}${PTEST_PATH}/test
- cp -rf ${B}*_test ${D}${PTEST_PATH}/test/
+ cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
}
FILES_${PN} += "${datadir}/** "