summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb16
1 files changed, 3 insertions, 13 deletions
diff --git a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb
index d1e97c4e0d..6cc04ac622 100644
--- a/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb
+++ b/meta-phosphor/recipes-phosphor/sensors/phosphor-hwmon-config-mrw.bb
@@ -1,54 +1,44 @@
SUMMARY = "Phosphor hwmon configuration generator"
DESCRIPTION = "Generate phosphor-hwmon configuration from an MRW."
-PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+DEPENDS += "mrw-perl-tools-native mrw-native"
+PR = "r1"
inherit allarch
inherit mrw-xml
-DEPENDS += "mrw-perl-tools-native mrw-native"
-
do_compile:append() {
${STAGING_BINDIR_NATIVE}/perl-native/perl \
${STAGING_BINDIR_NATIVE}/hwmon.pl \
-x ${mrw_datadir}/${MRW_XML} \
-d ${WORKDIR}/mrw-config-files
}
+do_install[postfuncs] += "install_conf_files"
def find_conf_files(dir):
from fnmatch import fnmatch
myfiles = []
-
#These conf files generated by hwmon.pl are in
#subdirectories which we need to preserve the path to.
for root, dirs, files in os.walk(dir):
for name in files:
if fnmatch(name, "*.conf"):
myfiles.append(os.path.join(root, name))
-
return myfiles
-
python install_conf_files() {
from shutil import copy
-
conf_file_dir = os.path.join(
d.getVar("WORKDIR", True),
'mrw-config-files')
files = find_conf_files(conf_file_dir)
-
install_dir = os.path.join(d.getVar("D", True),
"etc", "default", "obmc", "hwmon")
-
dir_len = len(conf_file_dir)
-
for f in files:
dest = os.path.join(install_dir, f[dir_len + 1:])
parent = os.path.dirname(dest)
if not os.path.exists(parent):
os.makedirs(parent)
-
copy(f, dest)
}
-
-do_install[postfuncs] += "install_conf_files"