summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/settings
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-08-23 18:04:46 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-08-23 18:35:23 +0300
commit6b62f1ecb8b4cc53828eaad1451ff776e98f5cda (patch)
treefae10a18a4ca3fc3aa23c0f1820483accd5c6533 /meta-phosphor/recipes-phosphor/settings
parent12a5ed5ab1992adbb5b49bdcd67a2da9d7b4b4f1 (diff)
downloadopenbmc-6b62f1ecb8b4cc53828eaad1451ff776e98f5cda.tar.xz
phosphor-settings-defaults: fix silent failures in install
If a file is missing from SETTINGS_HOST_TEMPLATES, the previous `do_install` would silently fail because bash by default does not use the `pipefail` option. Avoid the pipe operation so failures are more obvious: ``` | sed: can't read restrictionmode-host-settings.override.yml: No such file or directory | WARNING: .../lf-build-bletchley/tmp/work/x86_64-linux/phosphor-settings-defaults-native/1.0-r1/temp/run.do_install.800503:152 exit 2 from 'sed "s/{}/${i}/g" ${f} >> ${DEST}/defaults.yaml' ``` Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: If35ca6cbf1c1793229432cb680e6fc0148f721a2
Diffstat (limited to 'meta-phosphor/recipes-phosphor/settings')
-rw-r--r--meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb
index 98ee696495..4aac9bf60f 100644
--- a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb
+++ b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb
@@ -24,7 +24,7 @@ do_install() {
do
for f in ${SETTINGS_HOST_TEMPLATES};
do
- cat ${f} | sed "s/{}/${i}/g" >> ${DEST}/defaults.yaml
+ sed "s/{}/${i}/g" ${f} >> ${DEST}/defaults.yaml
done
done
}