summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/settings
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-04-15 00:15:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-04-15 04:27:47 +0300
commitb858c0e167717b012ffecf56904d797d307a96ab (patch)
treef63f9f4aea7a75137fa3e779d3fef34ada93db46 /meta-phosphor/recipes-phosphor/settings
parent439bbc91cd23a4969b1365ae19d681bea921a8ea (diff)
downloadopenbmc-b858c0e167717b012ffecf56904d797d307a96ab.tar.xz
phosphor-settings-defaults: allow additonal host templates
Previously we supported a single default per-host template, which enables default settings for multi-host designs. Add a variable, SETTINGS_HOST_TEMPLATES, which allows machines to add their own template snippets. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I1e416e2af8b336017c800676efd0183f294168a9
Diffstat (limited to 'meta-phosphor/recipes-phosphor/settings')
-rw-r--r--meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb
index 79fe68ab4a..98ee696495 100644
--- a/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb
+++ b/meta-phosphor/recipes-phosphor/settings/phosphor-settings-defaults-native.bb
@@ -11,6 +11,8 @@ SRC_URI += "file://host-template.yaml"
PROVIDES += "virtual/phosphor-settings-defaults"
+SETTINGS_HOST_TEMPLATES:append = " host-template.yaml"
+
S = "${WORKDIR}"
do_install() {
@@ -20,7 +22,9 @@ do_install() {
for i in ${OBMC_HOST_INSTANCES};
do
- cat host-template.yaml | sed "s/{}/${i}/g" >> ${DEST}/defaults.yaml
-
+ for f in ${SETTINGS_HOST_TEMPLATES};
+ do
+ cat ${f} | sed "s/{}/${i}/g" >> ${DEST}/defaults.yaml
+ done
done
}