summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/state
diff options
context:
space:
mode:
authorKumar Thangavel <thangavel.k@hcl.com>2022-12-07 17:45:58 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-01-31 20:09:15 +0300
commit2136731503545a2846c92d4caf8547ab2d58bcf8 (patch)
tree02ca35b8e4941cebb950b6e925a11da160812427 /meta-phosphor/recipes-phosphor/state
parentb9af8750acfaddd4a8b99c3e289510b5476c90f3 (diff)
downloadopenbmc-2136731503545a2846c92d4caf8547ab2d58bcf8.tar.xz
Removed extra added postcode manager dbus service
In current code, Extra Postcode manager dbus service name had added for our multi host systems which have 4 hosts[1-4] Ex : PostCode0, PostCode[1-4]. PostCode0 is not needed for our multi host system. So, this change removes the extra PostCode0 dbus services by removing default PostCode.service file. As per design, dbus service naming conventions as follows single host - xyz.openbmc_project.State.Boot.PostCode0 multi host system - xyz.openbmc_project.State.Boot.PostCode1 xyz.openbmc_project.State.Boot.PostCode2 xyz.openbmc_project.State.Boot.PostCode3 xyz.openbmc_project.State.Boot.PostCode4(N) xyz.openbmc_project.State.Boot.PostCode0 was added additionally for multi host systems which has been removed in this patch TESTED : Verified all host postcode dbus services are displayed correctly and tested in Facebook YosemiteV2/Tiogapass platform Signed-off-by: Kumar Thangavel <thangavel.k@hcl.com> Change-Id: I8ba9674cd8cd124b659649526aace093684ad612
Diffstat (limited to 'meta-phosphor/recipes-phosphor/state')
-rw-r--r--meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb b/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
index 409b56ee41..37c6f8eeff 100644
--- a/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/state/phosphor-post-code-manager_git.bb
@@ -14,11 +14,8 @@ S = "${WORKDIR}/git"
inherit meson pkgconfig systemd
def get_service(d):
- service_list = "xyz.openbmc_project.State.Boot.PostCode.service xyz.openbmc_project.State.Boot.PostCode@.service "
- if(d.getVar('OBMC_HOST_INSTANCES') == '0'):
- return service_list
- else:
- return service_list+" ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
+ return " ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
+
SYSTEMD_SERVICE:${PN} = "${@get_service(d)}"
DEPENDS += " \
sdbusplus \
@@ -26,3 +23,5 @@ DEPENDS += " \
phosphor-logging \
libcereal \
"
+FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode@.service"
+FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode.service"