summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2022-05-11 17:15:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2022-05-11 17:17:49 +0300
commit5b31c36076556d28f072484d3bda45e851b71311 (patch)
tree8957341e3709826e09dfd06ff2feeac614c6de10 /meta-phosphor/recipes-phosphor
parent21e9a7487d3b871732958155d0a28f49b445871b (diff)
downloadopenbmc-5b31c36076556d28f072484d3bda45e851b71311.tar.xz
meta-phosphor: add allowlist ipmid PACKAGECONFIG
Add a PACKAGECONFIG for the allowlist feature, so it can be disabled without using EXTRA_OECONF and comply with the OpenBMC meta layer guidelines. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Change-Id: I263dc9e8f9f65cc184482b149bcabe01b765326a
Diffstat (limited to 'meta-phosphor/recipes-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index 819435f3ec..7ad4016de0 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -21,10 +21,11 @@ def ipmi_whitelists(d):
whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
return ' '.join(whitelists)
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "allowlist"
PACKAGECONFIG[dynamic-sensors] = "--enable-dynamic-sensors,--disable-dynamic-sensors"
PACKAGECONFIG[hybrid-sensors] = "--enable-hybrid-sensors,--disable-hybrid-sensors"
PACKAGECONFIG[sel-logger-clears-sel] = "--enable-sel-logger-clears-sel,--disable-sel-logger-clears-sel"
+PACKAGECONFIG[allowlist] = "--enable-ipmi-whitelist,--disable-ipmi-whitelist"
DEPENDS += "autoconf-archive-native"
DEPENDS += "nlohmann-json"