summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor
diff options
context:
space:
mode:
authorJohnathan Mantey <johnathanx.mantey@intel.com>2023-05-12 01:21:26 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-05-12 22:28:18 +0300
commit934425b56094fa7b71f2c6b949bd340077555e32 (patch)
treebe8b9200d6add0befa898b30ce01ebdfcdc5267f /meta-phosphor/recipes-phosphor
parentf56508d1ddbf55093fbdc54b14404cc8ee794ea5 (diff)
downloadopenbmc-934425b56094fa7b71f2c6b949bd340077555e32.tar.xz
Add the abilty to enable/disable the USING_ENTITY_MANAGER_DECORATORS
The dbus-sdr/storagecommands.cpp file has a #ifdef compile time switch wrapping code that enables a D-Bus decorators interface. The code is enabled, via a hard-coded definition. Modify enabling and disabling this code by adding a PACAKGECONFIG variable instead. The feature is enabled by default, duplicating the current behavior. Change-Id: Ic482243d4286a4107cc7b59ed1ced69699351fda Signed-off-by: Johnathan Mantey <johnathanx.mantey@intel.com>
Diffstat (limited to 'meta-phosphor/recipes-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
index ac0a09d137..1935b5489a 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-host_git.bb
@@ -21,7 +21,7 @@ def ipmi_whitelists(d):
whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
return ' '.join(whitelists)
-PACKAGECONFIG ??= "allowlist i2c-allowlist boot-flag-safe-mode softoff libuserlayer"
+PACKAGECONFIG ??= "allowlist i2c-allowlist boot-flag-safe-mode softoff libuserlayer entity-manager-decorators"
PACKAGECONFIG[dynamic-sensors] = "-Ddynamic-sensors=enabled,-Ddynamic-sensors=disabled"
PACKAGECONFIG[hybrid-sensors] = "-Dhybrid-sensors=enabled,-Dhybrid-sensors=disabled"
PACKAGECONFIG[sel-logger-clears-sel] = "-Dsel-logger-clears-sel=enabled,-Dsel-logger-clears-sel=disabled"
@@ -33,6 +33,7 @@ PACKAGECONFIG[softoff] = "-Dsoftoff=enabled,-Dsoftoff=disabled"
PACKAGECONFIG[update-functional-on-fail] = "-Dupdate-functional-on-fail=enabled,-Dupdate-functional-on-fail=disabled"
PACKAGECONFIG[libuserlayer] = "-Dlibuserlayer=enabled,-Dlibuserlayer=disabled"
PACKAGECONFIG[sensors-cache] = "-Dsensors-cache=enabled,-Dsensors-cache=disabled"
+PACKAGECONFIG[entity-manager-decorators] = "-Dentity-manager-decorators=enabled,-Dentity-manager-decorators=disabled"
DEPENDS += "nlohmann-json"