summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support/boost/boost_%.bbappend
diff options
context:
space:
mode:
authorEd Tanous <ed@tanous.net>2020-10-17 00:42:00 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-10-21 00:20:42 +0300
commit57acb4680f999e0b2ab96e87fa5313defddeb577 (patch)
tree315a067b1f9c1b8b19b83bf13fb6190d37c25e0a /meta-phosphor/recipes-support/boost/boost_%.bbappend
parentb31b94d7cea773a9ba910c40ad94200c6999d50d (diff)
downloadopenbmc-57acb4680f999e0b2ab96e87fa5313defddeb577.tar.xz
Move context and coroutine
Yocto upstream moved context and coroutine directly into BOOST_LIBS, which means that they're not added back for our arm variant. https://github.com/lgirdk/poky/commit/624262541605c476f5a0bd415b08d00379c15b00 This causes our build to fail with "cannot find -lboost_coroutine" errors. This should resolve it. Tested: Fixing CI break. No functional testing done. (From meta-phosphor rev: 6be1787fdc13405fa9daa6755c28534bbcaa7458) Signed-off-by: Ed Tanous <ed@tanous.net> Change-Id: I60d7bb8ea25a08bfdb399f8addfaf560fd7a7b7c Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-support/boost/boost_%.bbappend')
-rw-r--r--meta-phosphor/recipes-support/boost/boost_%.bbappend12
1 files changed, 5 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-support/boost/boost_%.bbappend b/meta-phosphor/recipes-support/boost/boost_%.bbappend
index b614346aff..fabb7f55e9 100644
--- a/meta-phosphor/recipes-support/boost/boost_%.bbappend
+++ b/meta-phosphor/recipes-support/boost/boost_%.bbappend
@@ -1,12 +1,10 @@
#This is largely to improve our build times by not building or installing
-#modules that OpenBMC does not use by our coding standard. Another thing to
-#note is that for most targets, coroutine and context libraries are also added
-#with a BOOST_LIBS_append_<platform> for most targets. Chrono/Thread should not
-#be relied directly, but are required dependencies of context and coroutine.
-#See the relevant portion of the openbmc coding standard with regards to boost
-#libraries
+#modules that OpenBMC does not use by our coding standard. Chrono and Thread
+#should not be relied directly, but are required dependencies of context and
+#coroutine at build time. See the relevant portion of the openbmc coding
+#standard with regards to boost libraries
#
#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
#
-#BOOST_LIBS_openbmc-phosphor = "chrono thread"
+BOOST_LIBS_openbmc-phosphor = "chrono context coroutine thread"