summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2022-08-25 21:40:15 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-01 01:14:13 +0300
commit0be39b350fde000ff84e6da5e4387da5eef050e2 (patch)
tree31a5799cd9d19d2e04c519ef58d781283af1ad0f /meta-phosphor/recipes-support
parentac37d615e7d3e9ea973f5e3d60e677678d5c28ac (diff)
downloadopenbmc-0be39b350fde000ff84e6da5e4387da5eef050e2.tar.xz
Remove boost PACKAGECONFIG for class-target
Some BOOST_LIBS such as python and locale are being added by PACKAGECONFIG. Since we want to limit to the small set of BOOST_LIBS by default, we can remove anything added by PACKAGECONFIG for class-target. We found that boost-python is meeting the openssl dependency in the background, so we also have to add an explicit openssl dependency to build some applications without boost-python. This also updates the existing BOOST_LIBS change to only affect class-target. Change-Id: I6cd64354ac65ba60b0672a67b9d9e3a7dbe34b01 Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Diffstat (limited to 'meta-phosphor/recipes-support')
-rw-r--r--meta-phosphor/recipes-support/boost/boost_%.bbappend3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-support/boost/boost_%.bbappend b/meta-phosphor/recipes-support/boost/boost_%.bbappend
index 7aaa35c695..475c830c7b 100644
--- a/meta-phosphor/recipes-support/boost/boost_%.bbappend
+++ b/meta-phosphor/recipes-support/boost/boost_%.bbappend
@@ -8,5 +8,6 @@
#
#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
#
-BOOST_LIBS:openbmc-phosphor = "chrono thread context coroutine"
+BOOST_LIBS:openbmc-phosphor:class-target = "chrono thread context coroutine"
+PACKAGECONFIG:openbmc-phosphor:class-target = ""