summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-support
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-support
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-support')
-rw-r--r--meta-phosphor/recipes-support/boost/boost_%.bbappend4
-rw-r--r--meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb58
-rw-r--r--meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend1
-rw-r--r--meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend9
4 files changed, 31 insertions, 41 deletions
diff --git a/meta-phosphor/recipes-support/boost/boost_%.bbappend b/meta-phosphor/recipes-support/boost/boost_%.bbappend
index 475c830c7b..eb16acaa21 100644
--- a/meta-phosphor/recipes-support/boost/boost_%.bbappend
+++ b/meta-phosphor/recipes-support/boost/boost_%.bbappend
@@ -1,3 +1,5 @@
+PACKAGECONFIG:openbmc-phosphor:class-target = ""
+
#This is largely to improve our build times by not building or installing
#modules that OpenBMC does not use by our coding standard. Another thing to
#note is that for most targets, coroutine and context libraries are also added
@@ -9,5 +11,3 @@
#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
#
BOOST_LIBS:openbmc-phosphor:class-target = "chrono thread context coroutine"
-PACKAGECONFIG:openbmc-phosphor:class-target = ""
-
diff --git a/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb b/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
index 04e6a7e096..8c699a8b44 100644
--- a/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
+++ b/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
@@ -5,57 +5,49 @@ DESCRIPTION = "\
system information from LDAP. It is used by the libnss-ldapd and \
libpam-ldapd packages but is not very useful by itself. \
"
-
HOMEPAGE = "http://arthurdejong.org/nss-pam-ldapd/"
-
+SECTION = "base"
LICENSE = "LGPL-2.1-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-SECTION = "base"
-
FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+DEPENDS += "libpam openldap krb5"
SRC_URI = "\
- http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \
- file://nslcd.init \
- file://nslcd.service \
- "
-
-inherit autotools
-
+ http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \
+ file://nslcd.init \
+ file://nslcd.service \
+ "
SRC_URI[md5sum] = "8c99fdc54f4bf9aca8c5f53fdb1403ff"
SRC_URI[sha256sum] = "ef7362e7f2003da8c7beb7bcc03c30494acf712625aaac8badc6e7eb16f3453f"
-DEPENDS += "libpam openldap krb5"
+SYSTEMD_SERVICE:${PN} = "nslcd.service"
-RDEPENDS:${PN} += "nscd"
+inherit autotools
+inherit update-rc.d systemd
EXTRA_OECONF = "\
- --disable-pynslcd \
- --libdir=${base_libdir} \
- --with-pam-seclib-dir=${base_libdir}/security \
- "
-
-CONFFILES:${PN} += "${sysconfdir}/nslcd.conf"
-
-FILES:${PN} += "${base_libdir}/security ${datadir}"
-FILES:${PN}-dbg += "${base_libdir}/security/.debug"
-
-LDAP_DN ?= "dc=my-domain,dc=com"
+ --disable-pynslcd \
+ --libdir=${base_libdir} \
+ --with-pam-seclib-dir=${base_libdir}/security \
+ "
do_install:append() {
- install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
+ install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
+ sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
+ sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
+ sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_system_unitdir}
+}
- sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
- sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
- sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
+RDEPENDS:${PN} += "nscd"
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_system_unitdir}
-}
+FILES:${PN} += "${base_libdir}/security ${datadir}"
+FILES:${PN}-dbg += "${base_libdir}/security/.debug"
-inherit update-rc.d systemd
+CONFFILES:${PN} += "${sysconfdir}/nslcd.conf"
INITSCRIPT_NAME = "nslcd"
INITSCRIPT_PARAMS = "defaults"
-SYSTEMD_SERVICE:${PN} = "nslcd.service"
+LDAP_DN ?= "dc=my-domain,dc=com"
diff --git a/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend b/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
index 58ab64aae7..98f94a7af0 100644
--- a/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
+++ b/meta-phosphor/recipes-support/nss-pam-ldapd_fix/nss-pam-ldapd_%.bbappend
@@ -1,5 +1,4 @@
do_install:append() {
sed -i -e '$anss_initgroups_ignoreusers ALLLOCAL' ${D}${sysconfdir}/nslcd.conf
-
install -m 0644 ${D}${sysconfdir}/nslcd.conf ${D}${sysconfdir}/nslcd.conf.default
}
diff --git a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
index 98e8130a45..ab6f528af7 100644
--- a/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
+++ b/meta-phosphor/recipes-support/rng-tools/rng-tools_%.bbappend
@@ -1,17 +1,14 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://10-nice.conf"
-
PACKAGECONFIG:remove = "\
${@bb.utils.contains('MACHINE_FEATURES', 'hw-rng', \
'libjitterentropy', '', d)}\
"
-inherit systemd
+SRC_URI += "file://10-nice.conf"
-FILES:${PN} += "${systemd_system_unitdir}/rngd.service.d"
+inherit systemd
do_install:append() {
-
# When using systemd and using libjitterentropy, install a config
# which runs rngd at a 'nice' priority. libjitterentropy uses a
# lot of CPU early on in the boot process and makes the whole boot
@@ -24,3 +21,5 @@ do_install:append() {
fi
fi
}
+
+FILES:${PN} += "${systemd_system_unitdir}/rngd.service.d"