summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@intel.com>2022-02-17 02:18:31 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-02-17 16:22:55 +0300
commit686abc91115fb538cedf52204ee0558c340504fa (patch)
tree256895897c3af7907050477d1c02152314662ae7 /meta-phosphor
parent1581fb80734924cab801cada25f4361d49bbaa50 (diff)
downloadopenbmc-686abc91115fb538cedf52204ee0558c340504fa.tar.xz
meta-phosphor: Use '=' with append
Yocto has started throwing WARNINGs about using 'append' with '+=': WARNING: ...:append += is not a recommended operator combination, please replace it. This changes the '+=' in those cases to '=' and adds a leading space when needed. Tested: confirmed that it builds without these warnings Signed-off-by: Jason M. Bills <jason.m.bills@intel.com> Change-Id: I970e06ca6f9d0a9792af122eb25da1bb9a06f058
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend2
-rw-r--r--meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend6
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
index 5d0da5825e..18cb48e306 100644
--- a/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
+++ b/meta-phosphor/recipes-connectivity/avahi/avahi_%.bbappend
@@ -2,7 +2,7 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/avahi-daemon:"
SRC_URI += "file://avahi-daemon-override.conf"
-FILES:avahi-daemon:append += "${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf"
+FILES:avahi-daemon:append = " ${systemd_system_unitdir}/avahi-daemon.service.d/avahi-daemon-override.conf"
do_install:append() {
diff --git a/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend b/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend
index f4f3b42d02..e921c809c7 100644
--- a/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend
+++ b/meta-phosphor/recipes-devtools/rsync/rsync_%.bbappend
@@ -1,6 +1,6 @@
-EXTRA_OECONF:append:class-target += " --disable-largefile --disable-locale \
- --disable-iconv --without-included-popt \
- --without-included-zlib"
+EXTRA_OECONF:append:class-target = " --disable-largefile --disable-locale \
+ --disable-iconv --without-included-popt \
+ --without-included-zlib"
PACKAGECONFIG = ""