summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-02-18 23:47:01 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-02-22 21:04:04 +0300
commita95e0907e4ced0ba950449b7ef1b04e2c75a5381 (patch)
treed972910fbd3f74e5c0cfb74831b5f7c48be16a6f /meta-phosphor
parent8045cc5ec966ad1de76531b6ea6b3e8322a2b48b (diff)
downloadopenbmc-a95e0907e4ced0ba950449b7ef1b04e2c75a5381.tar.xz
meta-phosphor: migrate nuvoton-layer to dynamic-layers
The proper way to add extensions to another layer is with BBFILES_DYNAMIC rather than adding to BBFILES based on BBFILE_COLLECTIONS. Move nuvoton-layer to a dynamic-layers subdirectory and hook into layer.conf using BBFILES_DYNAMIC. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ic1b1f0ce837a899c5060531735c75c73cf51f1f5
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/conf/layer.conf2
-rw-r--r--meta-phosphor/dynamic-layers/nuvoton-layer/recipes-bsp/u-boot/u-boot-nuvoton_%.bbappend (renamed from meta-phosphor/nuvoton-layer/recipes-bsp/u-boot/u-boot-nuvoton_%.bbappend)0
-rwxr-xr-xmeta-phosphor/dynamic-layers/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd/state_hook (renamed from meta-phosphor/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd/state_hook)0
-rw-r--r--meta-phosphor/dynamic-layers/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd_git.bbappend (renamed from meta-phosphor/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd_git.bbappend)0
-rw-r--r--meta-phosphor/dynamic-layers/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend (renamed from meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend)0
-rw-r--r--meta-phosphor/dynamic-layers/nuvoton-layer/recipes-phosphor/host/phosphor-host-postd_%.bbappend (renamed from meta-phosphor/nuvoton-layer/recipes-phosphor/host/phosphor-host-postd_%.bbappend)0
6 files changed, 2 insertions, 0 deletions
diff --git a/meta-phosphor/conf/layer.conf b/meta-phosphor/conf/layer.conf
index 787b36dc52..0041dfc29e 100644
--- a/meta-phosphor/conf/layer.conf
+++ b/meta-phosphor/conf/layer.conf
@@ -23,4 +23,6 @@ BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
BBFILES_DYNAMIC += " \
aspeed-layer:${LAYERDIR}/dynamic-layers/aspeed-layer/recipes-*/*/*.bb \
aspeed-layer:${LAYERDIR}/dynamic-layers/aspeed-layer/recipes-*/*/*.bbappend \
+ nuvoton-layer:${LAYERDIR}/dynamic-layers/nuvoton-layer/recipes-*/*/*.bb \
+ nuvoton-layer:${LAYERDIR}/dynamic-layers/nuvoton-layer/recipes-*/*/*.bbappend \
"
diff --git a/meta-phosphor/nuvoton-layer/recipes-bsp/u-boot/u-boot-nuvoton_%.bbappend b/meta-phosphor/dynamic-layers/nuvoton-layer/recipes-bsp/u-boot/u-boot-nuvoton_%.bbappend
index ab57dadb31..ab57dadb31 100644
--- a/meta-phosphor/nuvoton-layer/recipes-bsp/u-boot/u-boot-nuvoton_%.bbappend
+++ b/meta-phosphor/dynamic-layers/nuvoton-layer/recipes-bsp/u-boot/u-boot-nuvoton_%.bbappend
diff --git a/meta-phosphor/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd/state_hook b/meta-phosphor/dynamic-layers/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd/state_hook
index d317e2e9b7..d317e2e9b7 100755
--- a/meta-phosphor/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd/state_hook
+++ b/meta-phosphor/dynamic-layers/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd/state_hook
diff --git a/meta-phosphor/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd_git.bbappend b/meta-phosphor/dynamic-layers/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd_git.bbappend
index 1061a9271f..1061a9271f 100644
--- a/meta-phosphor/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd_git.bbappend
+++ b/meta-phosphor/dynamic-layers/nuvoton-layer/recipes-connectivity/jsnbd/jsnbd_git.bbappend
diff --git a/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend b/meta-phosphor/dynamic-layers/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
index 848627ac75..848627ac75 100644
--- a/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
+++ b/meta-phosphor/dynamic-layers/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
diff --git a/meta-phosphor/nuvoton-layer/recipes-phosphor/host/phosphor-host-postd_%.bbappend b/meta-phosphor/dynamic-layers/nuvoton-layer/recipes-phosphor/host/phosphor-host-postd_%.bbappend
index 7ab27ce0bd..7ab27ce0bd 100644
--- a/meta-phosphor/nuvoton-layer/recipes-phosphor/host/phosphor-host-postd_%.bbappend
+++ b/meta-phosphor/dynamic-layers/nuvoton-layer/recipes-phosphor/host/phosphor-host-postd_%.bbappend