summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorJorge Cisneros <jcisneros3@lenovo.com>2022-02-16 00:01:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-02-16 19:33:58 +0300
commit14cef4e6c4d3e206d43cc9653e479a5a331f06ab (patch)
treedb99b1acba65ad505bb8f7885e88200b74c8911b /meta-phosphor
parent5885e07234f3628287cbdaab5862d77c63e7f767 (diff)
downloadopenbmc-14cef4e6c4d3e206d43cc9653e479a5a331f06ab.tar.xz
webui-vue: enable network access during build
Network access is disabled by Yocto in all tasks except do_fetch on kernels compiled with CONFIG_NET_NS enabled, like the kernel 5.4.0-97 on Ubuntu 20.04 The logs show the error, for example, this one. | npm ERR! code EAI_AGAIN | npm ERR! syscall getaddrinfo | npm ERR! errno EAI_AGAIN | npm ERR! request to https://registry.npmjs.org/y18n/-/y18n-4.0.0.tgz failed, reason: getaddrinfo EAI_AGAIN registry.npmjs.org you can read more about this here https://git.yoctoproject.org/poky/tree/documentation/migration-guides/migration-3.5.rst#n25 Note: This is just a workaround, a better solution should be to use the yocto npm-fetcher Signed-off-by: Jorge Cisneros <jcisneros3@lenovo.com> Change-Id: I84787cb603ae8ef36cac973a6e0dbc6da030a698
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
index de4ec2e151..cc24c65b91 100644
--- a/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
+++ b/meta-phosphor/recipes-phosphor/webui/webui-vue_git.bb
@@ -32,6 +32,11 @@ FILES:${PN} += "${datadir}/www/*"
EXTRA_OENPM ?= ""
+# Workaround
+# Network access from task are disabled by default on Yocto 3.5
+# https://git.yoctoproject.org/poky/tree/documentation/migration-guides/migration-3.5.rst#n25
+do_compile[network] = "1"
+
do_compile () {
cd ${S}
rm -rf node_modules