summaryrefslogtreecommitdiff
path: root/meta-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2024-02-05 22:37:47 +0300
committerPatrick Williams <patrick@stwcx.xyz>2024-02-07 04:43:57 +0300
commit206fa2169cc7c722fa10073ff3e76f7edef486f5 (patch)
tree9caa91962e756de0b6005e34d9b275cbfb68dca0 /meta-phosphor
parent6fd62ea8d86f000a2dc0d21ad1ea48e5182e2323 (diff)
downloadopenbmc-206fa2169cc7c722fa10073ff3e76f7edef486f5.tar.xz
meta-phosphor: obmc-console: remove excess install for non-ssh
When the "ssh" `PACKAGECONFIG` is disabled, we should not install some configuration related to SSH: 1. The `dropbear.env` file. 2. The Avahi / SLP registration for the client console SSH port. Utilize PACKAGECONFIG accordingly. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I3ebb09c9b09c239c259697d361a5fe8f0c8c0f11
Diffstat (limited to 'meta-phosphor')
-rw-r--r--meta-phosphor/recipes-phosphor/console/obmc-console_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
index 00520db668..09c133f5fd 100644
--- a/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
+++ b/meta-phosphor/recipes-phosphor/console/obmc-console_git.bb
@@ -36,7 +36,9 @@ do_install:append() {
# Install the server configuration
install -m 0755 -d ${D}${sysconfdir}/${BPN}
- install -m 0644 ${WORKDIR}/dropbear.env ${D}${sysconfdir}/${BPN}/
+ if ${@bb.utils.contains('PACKAGECONFIG', 'ssh', 'true', 'false', d)} ; then
+ install -m 0644 ${WORKDIR}/dropbear.env ${D}${sysconfdir}/${BPN}/
+ fi
# If the OBMC_CONSOLE_TTYS variable is used without the default OBMC_CONSOLE_HOST_TTY
# the port specific config file should be provided. If it is just OBMC_CONSOLE_HOST_TTY,
@@ -80,7 +82,7 @@ FILES:${PN} += "${systemd_system_unitdir}"
TARGET_CFLAGS += "-fpic -O2"
-REGISTERED_SERVICES:${PN} += "obmc_console:tcp:2200:"
+REGISTERED_SERVICES:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'ssh', 'obmc_console:tcp:2200:', '', d)}"
OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
# Support multiple TTY ports using space separated list.
# Ex. OBMC_CONSOLE_TTYS = "ttyS1 ttyS2"