summaryrefslogtreecommitdiff
path: root/meta-quanta
diff options
context:
space:
mode:
authorJoseph Fu <joseph.fu@quantatw.com>2022-01-28 06:16:04 +0300
committerJoseph Fu <joseph.fu@quantatw.com>2022-02-24 04:17:59 +0300
commit26da90befcb4633d7ab5ba2e54b8515e7402bdb9 (patch)
treef6f8724fcd72bb695dff1fd82820ecb637bd31ef /meta-quanta
parenta9de0df0c17ca93cdf86a978f46c574b9c6ec095 (diff)
downloadopenbmc-26da90befcb4633d7ab5ba2e54b8515e7402bdb9.tar.xz
meta-quanta: s6q: enable the boot type selector
Enable the BIOS boot type. Add 'boot_type' option for phosphor-settings-manager to support both EFI and Legacy boot. Tested: ~# ipmitool raw 0x00 0x09 0x05 0x00 0x00 01 05 60 00 00 00 00 ~# ipmitool chassis bootparam get 5 Boot parameter version: 1 Boot parameter 5 is valid/unlocked Boot parameter data: 6000000000 Boot Flags : BIOS EFI boot ~# ipmitool raw 0x00 0x08 0x05 0x80 0x00 0x00 0x00 0x00 ~# ipmitool raw 0x00 0x09 0x05 0x00 0x00 01 05 80 00 00 00 00 ~# ipmitool chassis bootparam get 5 Boot parameter version: 1 Boot parameter 5 is valid/unlocked Boot parameter data: 8000000000 Boot Flags : BIOS PC Compatible (legacy) boot Signed-off-by: Joseph Fu <joseph.fu@quantatw.com> Change-Id: I3ff030dd65fad1a2492c20a6622c6dce68832b45
Diffstat (limited to 'meta-quanta')
-rw-r--r--meta-quanta/meta-s6q/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-quanta/meta-s6q/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend b/meta-quanta/meta-s6q/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
index 615702f2ea..abc9f5f5a4 100644
--- a/meta-quanta/meta-s6q/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
+++ b/meta-quanta/meta-s6q/recipes-phosphor/settings/phosphor-settings-manager_%.bbappend
@@ -3,3 +3,5 @@ FILESEXTRAPATHS:prepend:s6q := "${THISDIR}/${PN}:"
SRC_URI:append:s6q = " file://chassis-capabilities.override.yml \
file://power-policy-set-default.override.yml \
"
+
+PACKAGECONFIG:append:s6q = " boot_type"