summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/classes
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:54:03 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:54:10 +0300
commit26e4beaa6b6010b921ff99c1a3a7be148fbbfcbc (patch)
treeb57004eafa95be87bda454f13e34458f0a01f9f6 /meta-raspberrypi/classes
parent7eb438a61ba2d5b3cc7f0ac3fea1ca2e47390529 (diff)
downloadopenbmc-26e4beaa6b6010b921ff99c1a3a7be148fbbfcbc.tar.xz
meta-raspberrypi: subtree update:09a3c11696..3a1fec22c0
Jan-Simon Moeller (1): python3-sense-hat: Switch to using pillow instead of imaging module Jose Quaresma (3): gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin gstreamer1.0-plugins-good: enable rpicamsrc plugin gstreamer1.0-plugins-base: drop custom cppflags Khem Raj (9): linux-raspberrypi: Do not use += with append python3-sense-hat: Move to dynamic-layers layer.conf: Add hardknott (3.3) to acceptable releases linux-raspberrypi_5.4.bb: Update to 5.4.79 raspberrypi-firmware: Update to latest to take 5.4.79 prebuilts userland: Upgrade to latest as of 20201027 raspberrypi-tools: Update to latest on master armstubs: Always use gcc compiler packagegroup-rpi-test: Add python3-sense-hat in a meta-python specific bbappend Madhavan Krishnan (1): libcamera: Enabled camera overlays define based Martin Jansa (3): gstreamer1.0-omx: rename bbappend to match new 1.18.0 version from oe-core layer.conf: Remove older releases from LAYERSERIES_COMPAT Revert "gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin" Ming Liu (1): rpi-u-boot-scr: drop hard-coded 'arm' Paul Barker (9): linux-raspberrypi: Convert dynamic config patching to config fragments sdcard_image-rpi: Drop redundant dependency on rpi-config:do_deploy rpi-cmdline: Move cmdline.txt generation to a separate recipe bootfiles: Use BOOTFILES_DIR_NAME variable rpi-bootfiles: Rename recipe to avoid ambiguity linux-raspberrypi: Remove obsolete kernel versions linux-raspberrypi: Drop unused rpi-kernel-misc config fragment linux-raspberrypi: Merge v5.4 recipe & inc file linux-raspberrypi-dev: Update for testing v5.10.y Trevor Woerner (1): userland: add knob for ALL_APPS Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I90e0cba993e7f5bae2e56f2d40fd2f69211c2648
Diffstat (limited to 'meta-raspberrypi/classes')
-rw-r--r--meta-raspberrypi/classes/sdcard_image-rpi.bbclass6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta-raspberrypi/classes/sdcard_image-rpi.bbclass b/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
index 8197978a3a..0ae98cdab3 100644
--- a/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
+++ b/meta-raspberrypi/classes/sdcard_image-rpi.bbclass
@@ -25,9 +25,6 @@ inherit image_types
# This image depends on the rootfs image
IMAGE_TYPEDEP_rpi-sdimg = "${SDIMG_ROOTFS_TYPE}"
-# Set kernel and boot loader
-IMAGE_BOOTLOADER ?= "bootfiles"
-
# Kernel image name
SDIMG_KERNELIMAGE_raspberrypi ?= "kernel.img"
SDIMG_KERNELIMAGE_raspberrypi2 ?= "kernel7.img"
@@ -56,8 +53,7 @@ do_image_rpi_sdimg[depends] = " \
mtools-native:do_populate_sysroot \
dosfstools-native:do_populate_sysroot \
virtual/kernel:do_deploy \
- ${IMAGE_BOOTLOADER}:do_deploy \
- rpi-config:do_deploy \
+ rpi-bootfiles:do_deploy \
${@bb.utils.contains('MACHINE_FEATURES', 'armstub', 'armstubs:do_deploy', '' ,d)} \
${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \
${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot-default-script:do_deploy', '',d)} \