summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/docs/extra-build-config.md
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:54:03 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-12-01 04:54:10 +0300
commit26e4beaa6b6010b921ff99c1a3a7be148fbbfcbc (patch)
treeb57004eafa95be87bda454f13e34458f0a01f9f6 /meta-raspberrypi/docs/extra-build-config.md
parent7eb438a61ba2d5b3cc7f0ac3fea1ca2e47390529 (diff)
downloadopenbmc-26e4beaa6b6010b921ff99c1a3a7be148fbbfcbc.tar.xz
meta-raspberrypi: subtree update:09a3c11696..3a1fec22c0
Jan-Simon Moeller (1): python3-sense-hat: Switch to using pillow instead of imaging module Jose Quaresma (3): gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin gstreamer1.0-plugins-good: enable rpicamsrc plugin gstreamer1.0-plugins-base: drop custom cppflags Khem Raj (9): linux-raspberrypi: Do not use += with append python3-sense-hat: Move to dynamic-layers layer.conf: Add hardknott (3.3) to acceptable releases linux-raspberrypi_5.4.bb: Update to 5.4.79 raspberrypi-firmware: Update to latest to take 5.4.79 prebuilts userland: Upgrade to latest as of 20201027 raspberrypi-tools: Update to latest on master armstubs: Always use gcc compiler packagegroup-rpi-test: Add python3-sense-hat in a meta-python specific bbappend Madhavan Krishnan (1): libcamera: Enabled camera overlays define based Martin Jansa (3): gstreamer1.0-omx: rename bbappend to match new 1.18.0 version from oe-core layer.conf: Remove older releases from LAYERSERIES_COMPAT Revert "gstreamer1.0-plugins-good: add package config knob to enable rpicamsrc plugin" Ming Liu (1): rpi-u-boot-scr: drop hard-coded 'arm' Paul Barker (9): linux-raspberrypi: Convert dynamic config patching to config fragments sdcard_image-rpi: Drop redundant dependency on rpi-config:do_deploy rpi-cmdline: Move cmdline.txt generation to a separate recipe bootfiles: Use BOOTFILES_DIR_NAME variable rpi-bootfiles: Rename recipe to avoid ambiguity linux-raspberrypi: Remove obsolete kernel versions linux-raspberrypi: Drop unused rpi-kernel-misc config fragment linux-raspberrypi: Merge v5.4 recipe & inc file linux-raspberrypi-dev: Update for testing v5.10.y Trevor Woerner (1): userland: add knob for ALL_APPS Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I90e0cba993e7f5bae2e56f2d40fd2f69211c2648
Diffstat (limited to 'meta-raspberrypi/docs/extra-build-config.md')
-rw-r--r--meta-raspberrypi/docs/extra-build-config.md14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-raspberrypi/docs/extra-build-config.md b/meta-raspberrypi/docs/extra-build-config.md
index 84601848ef..921dcc5990 100644
--- a/meta-raspberrypi/docs/extra-build-config.md
+++ b/meta-raspberrypi/docs/extra-build-config.md
@@ -326,3 +326,17 @@ option:
# Raspberry Pi 7\" display/touch screen \n \
lcd_rotate=2 \n \
'
+## Enable Raspberrypi Camera V2
+
+RaspberryPi does not have the unicam device ( RaspberryPi Camera ) enabled by default.
+Because this unicam device ( bcm2835-unicam ) as of now is used by libcamera opensource.
+So we have to explicitly set in local.conf.
+
+ RASPBERRYPI_CAMERA_V2 = "1"
+
+This will add the device tree overlays imx219 ( RaspberryPi Camera sensor V2 driver ) to config.txt.
+Also, this will enable adding Contiguous Memory Allocation value in the cmdline.txt.
+
+Ref.:
+* <https://github.com/raspberrypi/documentation/blob/master/linux/software/libcamera/README.md>
+* <https://www.raspberrypi.org/blog/an-open-source-camera-stack-for-raspberry-pi-using-libcamera/>