summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-08-21 23:56:44 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-08-21 23:56:46 +0300
commit9d7e0aa351ef830384ea15f50f9ed0a9cf5ededd (patch)
tree4fa64f01f7aa5eecc7b8907dd42c97b42f7d821c /meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
parent472de4c08d44f1c8ebf6975961a98cc2eeef698e (diff)
downloadopenbmc-9d7e0aa351ef830384ea15f50f9ed0a9cf5ededd.tar.xz
meta-raspberrypi: subtree update:e2c1992955..cc6074c660
Andrei Gherzan (1): sdcard_image-rpi.bbclass: Fix when RPI_SDIMG_EXTRA_DEPENDS not defined Christopher Clark (2): sdcard_image-rpi.bbclass: enable extensible inclusion into boot docs/extra-build-config.md: document vars to add to boot partition Fabio Berton (1): u-boot: Move fw_env.config to u-boot append Jakub Luzny (2): rpi-config: Add CAN_OSCILLATOR variable to set mcp2515 crystal frequency docs/extra-build-config.md: Document CAN_OSCILLATOR variable Jeff Ithier (1): Generalize the naming of the bootfiles deploy directory Martin Jansa (1): linux-raspberrypi-5.4: bump SRCREV to latest to fix perf build Pierre-Jean Texier (3): rpi-default-versions: Switch defaults to 5.4 raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to revision 4b945d5 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I50eca26a801bfe014d3cea271f0cb91e7b653445
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb')
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
deleted file mode 100644
index d20312c14d..0000000000
--- a/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
+++ /dev/null
@@ -1,43 +0,0 @@
-DESCRIPTION = "Closed source binary files to help boot the ARM on the BCM2835."
-LICENSE = "Broadcom-RPi"
-
-LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=c403841ff2837657b2ed8e5bb474ac8d"
-
-inherit deploy nopackages
-
-include recipes-bsp/common/raspberrypi-firmware.inc
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-DEPENDS = "rpi-config"
-
-COMPATIBLE_MACHINE = "^rpi$"
-
-S = "${RPIFW_S}/boot"
-
-PR = "r3"
-
-do_deploy() {
- install -d ${DEPLOYDIR}/${PN}
-
- for i in ${S}/*.elf ; do
- cp $i ${DEPLOYDIR}/${PN}
- done
- for i in ${S}/*.dat ; do
- cp $i ${DEPLOYDIR}/${PN}
- done
- for i in ${S}/*.bin ; do
- cp $i ${DEPLOYDIR}/${PN}
- done
-
- # Add stamp in deploy directory
- touch ${DEPLOYDIR}/${PN}/${PN}-${PV}.stamp
-}
-
-do_deploy[depends] += "rpi-config:do_deploy"
-
-addtask deploy before do_build after do_install
-do_deploy[dirs] += "${DEPLOYDIR}/${PN}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-