summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-06-27 08:13:56 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-27 08:14:12 +0300
commit4fc9e431d19fba76d604f05afd8b9f478d30f462 (patch)
treec10d3341dae23968fef480f4698270ff1e1d65b6 /meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
parent84ad7c5b112283d1ccb14744025a2d2ba986412d (diff)
downloadopenbmc-4fc9e431d19fba76d604f05afd8b9f478d30f462.tar.xz
meta-raspberrypi: subtree update:39cf54c3cb..a6f1233d52
Jon Magnuson (1): packagegroup-rpi-test: resolve `wireless-regdb` conflict Khem Raj (1): linux-raspberrypi_5.4.bb: Upgrade to 5.4.47 Leon Anavi (7): lirc_%.bbappend: Fix for gpio-ir lirc: Move to dynamic-layers rpi-config: Add ENABLE_IR variable for infrared rpi-base.inc: Include modules if IR is enabled lirc_%.bbappend: Use lircd.service as in Raspbian docs/extra-build-config.md: Infrared lirc: Rename bbappend to match only version 0.10.1 M. ter Woord (1): Update layer-contents.md to include pi4 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I6f20c20dec1dd2fdab9e4e52dea1cdd54be4fffc
Diffstat (limited to 'meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb')
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index 5315676fdf..d964de5bf6 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -25,6 +25,8 @@ PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}"
VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
VC4DTBO ?= "vc4-kms-v3d"
+GPIO_IR ?= "18"
+GPIO_IR_TX ?= "17"
inherit deploy nopackages
@@ -161,6 +163,13 @@ do_deploy() {
echo "enable_uart=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi
+ # Infrared support
+ if [ "${ENABLE_IR}" = "1" ]; then
+ echo "# Enable infrared" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=gpio-ir,gpio_pin=${GPIO_IR}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=gpio-ir-tx,gpio_pin=${GPIO_IR_TX}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
# VC4 Graphics support
if [ "${VC4GRAPHICS}" = "1" ]; then
echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt