summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-devtools
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-03-06 00:21:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-03-15 14:02:06 +0300
commit3e34fba3f6b8389074f64203299fa60ec0fc18e1 (patch)
treec863d9d0adf9b551157b9d09c3870bc961038886 /meta-raspberrypi/recipes-devtools
parent46c2791f2c65f72b001533f3029228b85629aa1b (diff)
downloadopenbmc-3e34fba3f6b8389074f64203299fa60ec0fc18e1.tar.xz
meta-raspberrypi: subtree update:f5fe02c30c..853ccd7440
Chris Laplante (8): python3-adafruit-blinka: add recipe python3-adafruit-circuitpython-busdevice: add recipe python3-adafruit-circuitpython-motor: add recipe python3-adafruit-circuitpython-motorkit: add recipe python3-adafruit-circuitpython-pca9685: add recipe python3-adafruit-circuitpython-register: add recipe python3-adafruit-platformdetect: add recipe python3-adafruit-pureio: add recipe Jose Quaresma (3): gstreamer1.0-omx: drop custom cflags gstreamer1.0-omx: consolidate the append usage and only use one gstreamer1.0-omx: drop config-files-path.patch Khem Raj (2): python3-adafruit-blinka: Make rpi-gpio dependency conditional python3-adafruit-blinka: Delete microcontroller/bcm283x for non arm32 machines Martin Jansa (2): sdcard_image-rpi.bbclass: increase default boot partition size from 40MiB to 48MiB sdcard_image-rpi.bbclass: shorten the default BOOTDD_VOLUME_ID Mike Looijmans (1): overlays: Add "vc4-kms-dsi-7inch.dtbo" Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: If81a2227cc45daf24cd0b2466651658bb1b71eb0
Diffstat (limited to 'meta-raspberrypi/recipes-devtools')
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb30
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb18
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb18
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb22
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb20
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb15
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb15
-rw-r--r--meta-raspberrypi/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb19
8 files changed, 157 insertions, 0 deletions
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb
new file mode 100644
index 0000000000..7d3120f76d
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-blinka_6.2.2.bb
@@ -0,0 +1,30 @@
+SUMMARY = "CircuitPython APIs for non-CircuitPython versions of Python such as CPython on Linux and MicroPython."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_Blinka"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=660e614bc7efb0697cc793d8a22a55c2"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_Blinka.git"
+SRCREV = "dc688f354fe779c9267c208b99f310af87e79272"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+do_install_append() {
+# it ships ./bcm283x/pulseio/libgpiod_pulsein which is a prebuilt
+# 32bit binary therefore we should make this specific to 32bit rpi machines (based on bcm283x) only
+ if [ ${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '1', '0', d)} = "0" ]; then
+ rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/adafruit_blinka/microcontroller/bcm283x
+ fi
+}
+
+RDEPENDS_${PN} += " \
+ libgpiod \
+ python3-adafruit-platformdetect \
+ python3-adafruit-pureio \
+ python3-core \
+"
+
+RDEPENDS_${PN}_append_rpi = " rpi-gpio"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb
new file mode 100644
index 0000000000..c14d6f3d65
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-busdevice_5.0.5.bb
@@ -0,0 +1,18 @@
+SUMMARY = "CircuitPython bus device classes to manage bus sharing."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_BusDevice"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ec69d6e9e6c85adfb7799d7f8cf044e"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_BusDevice.git"
+SRCREV = "1bfe8005293205e2f7b2cc498ab5a946f1133b40"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += " \
+ python3-adafruit-blinka \
+ python3-core \
+"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
new file mode 100644
index 0000000000..e05e2ab5e1
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motor_3.2.6.bb
@@ -0,0 +1,18 @@
+SUMMARY = "CircuitPython helper library provides higher level objects to control motors and servos."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_Motor"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b72678307cc7c10910b5ef460216af07"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_Motor.git"
+SRCREV = "2251bfc0501d0acfb96c0a43f4f2b4c6a10ca14e"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += " \
+ python3-adafruit-blinka \
+ python3-core \
+"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
new file mode 100644
index 0000000000..f35d48cf26
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-motorkit_1.6.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "CircuitPython helper library for DC & Stepper Motor FeatherWing, Shield, and Pi Hat kits."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_MotorKit"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ad4a8854b39ad474755ef1aea813bac"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_MotorKit.git"
+SRCREV = "8c1462b4129b21f6db156d1517abb017bb74b982"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += " \
+ python3-adafruit-blinka \
+ python3-adafruit-circuitpython-busdevice \
+ python3-adafruit-circuitpython-motor \
+ python3-adafruit-circuitpython-pca9685 \
+ python3-adafruit-circuitpython-register \
+ python3-core \
+"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb
new file mode 100644
index 0000000000..0b65c81ea1
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-pca9685_3.3.4.bb
@@ -0,0 +1,20 @@
+SUMMARY = "CircuitPython driver for motor, stepper, and servo based on PCA9685."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_PCA9685"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e7eb6b599fb0cfb06485c64cd4242f62"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_PCA9685.git"
+SRCREV = "2780c4102f4c23fbab252aa1198b61ba7e2d1b2c"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += " \
+ python3-adafruit-blinka \
+ python3-adafruit-circuitpython-busdevice \
+ python3-adafruit-circuitpython-register \
+ python3-core \
+"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb
new file mode 100644
index 0000000000..f1af80bea7
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.4.bb
@@ -0,0 +1,15 @@
+SUMMARY = "CircuitPython data descriptor classes to represent hardware registers on I2C and SPI devices."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_Register"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ec69d6e9e6c85adfb7799d7f8cf044e"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_Register.git"
+
+S = "${WORKDIR}/git"
+SRCREV = "5fee6e0c3878110844bc51e16063eeae7d94c457"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+inherit setuptools3
+
+RDEPENDS_${PN} += "python3-core"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
new file mode 100644
index 0000000000..4454d247d7
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-platformdetect_3.1.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Platform detection for use by libraries like Adafruit-Blinka."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_Python_PlatformDetect"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fccd531dce4b989c05173925f0bbb76c"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_Python_PlatformDetect.git"
+SRCREV = "e0fe1b012898fa824944d6805ca74be0fa027968"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += "python3-core"
diff --git a/meta-raspberrypi/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb
new file mode 100644
index 0000000000..82415f9548
--- /dev/null
+++ b/meta-raspberrypi/recipes-devtools/python/python3-adafruit-pureio_1.1.8.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Pure python (i.e. no native extensions) access to Linux IO including I2C and SPI. Drop in replacement for smbus and spidev modules."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_Python_PureIO"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2a21fcca821a506d4c36f7bbecc0d009"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_Python_PureIO.git"
+SRCREV = "f4d0973da05b8b21905ff6bab69cdb652128f342"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS_${PN} += " \
+ python3-core \
+ python3-ctypes \
+ python3-fcntl \
+"