summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-graphics
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-09-18 21:33:52 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-18 21:33:55 +0300
commit19b4e6c6daefcbe72afe57874d2e48c43c418321 (patch)
treec28547b423cc216d1e511aa900c607a8b326a369 /meta-raspberrypi/recipes-graphics
parent214089240f2991c47237e9381f0078594998e744 (diff)
downloadopenbmc-19b4e6c6daefcbe72afe57874d2e48c43c418321.tar.xz
meta-raspberrypi: subtree update:cc6074c660..0e9c32c816
Andrzej Bednarski (1): docs: Correct minor spelling issues Khem Raj (6): linux-raspberrypi: Update to 5.4.59 raspberrypi-firmware: Upgrade to 20200819 xserver-xorg: Depend on userland when vc4graphics is disabled libsdl2: Add userland dependency when not using vc4graphics linux-raspberrypi_5.4.bb: Build ashmem and binder drivers README: Mention Yoe distro in supported distro list Luis Alfredo da Silva (1): Revert "mesa: querying dma_buf modifiers for specific formats" Martin Jansa (5): linux-raspberrypi-5.4: backport a fix for perf build with -fno-common from gcc-10 rpi-gpio: add -fcommon temporarily linux-raspberrypi-5.4: revert 1 commit from upstream to fix lttng-modules build raspberrypi-{firmware,tools}: set downloadfilename Revert "linux-raspberrypi-5.4: revert 1 commit from upstream to fix lttng-modules build" Pierre-Jean Texier (2): raspberrypi-firmware: update to current HEAD linux-raspberrypi: bump to Linux version 5.4.64 Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I5acc97c6612dd01922b1577537e555220f3b77e6
Diffstat (limited to 'meta-raspberrypi/recipes-graphics')
-rw-r--r--meta-raspberrypi/recipes-graphics/libsdl2/libsdl2_%.bbappend5
-rw-r--r--meta-raspberrypi/recipes-graphics/mesa/files/0001-dri2-query-dma-buf-modifiers.patch43
-rw-r--r--meta-raspberrypi/recipes-graphics/mesa/mesa_%.bbappend4
-rw-r--r--meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend4
4 files changed, 9 insertions, 47 deletions
diff --git a/meta-raspberrypi/recipes-graphics/libsdl2/libsdl2_%.bbappend b/meta-raspberrypi/recipes-graphics/libsdl2/libsdl2_%.bbappend
new file mode 100644
index 0000000000..cb9c24e4d4
--- /dev/null
+++ b/meta-raspberrypi/recipes-graphics/libsdl2/libsdl2_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+# when using userland graphic KHR/khrplatform.h is provided by userland but virtual/libgl is provided by mesa-gl where
+# we explicitly delete KHR/khrplatform.h since its already coming from userland package
+DEPENDS_append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'userland', d)}"
diff --git a/meta-raspberrypi/recipes-graphics/mesa/files/0001-dri2-query-dma-buf-modifiers.patch b/meta-raspberrypi/recipes-graphics/mesa/files/0001-dri2-query-dma-buf-modifiers.patch
deleted file mode 100644
index 0bda014505..0000000000
--- a/meta-raspberrypi/recipes-graphics/mesa/files/0001-dri2-query-dma-buf-modifiers.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-mesa: querying dma_buf_modifiers for specific formats
-
-mesa wl_drm protocol is the backend for wayland server side which requires
-the dmabuf modifiers for some DRM formats on specific devices like RPI.
-Currently there is no support of giving any dmabuf modifiers on wl_drm protocol.
-This dma_buf modifiers allows EGL implementations to add extra attributes
-to drm_fourcc format.
-
-Upstream-Status: Pending
-
-Signed-off-by: Balaji Velmurugan <balaji.velmurugan@ltts.com>
-
---- a/src/gallium/state_trackers/dri/dri2.c
-+++ b/src/gallium/state_trackers/dri/dri2.c
-@@ -1366,14 +1366,28 @@ dri2_from_planar(__DRIimage *image, int
- return img;
- }
-
-+static boolean
-+dri2_query_dma_buf_modifiers(__DRIscreen *_screen, int fourcc, int max,
-+ uint64_t *modifiers, unsigned int *external_only,
-+ int *count);
- static __DRIimage *
- dri2_from_fds(__DRIscreen *screen, int width, int height, int fourcc,
- int *fds, int num_fds, int *strides, int *offsets,
- void *loaderPrivate)
- {
-+ uint64_t modifier= DRM_FORMAT_MOD_INVALID;
-+ unsigned int external_only= 0;
-+ int count= 0;
-+ boolean result;
-+ result= dri2_query_dma_buf_modifiers( screen, fourcc, 1, &modifier, &external_only, &count);
-+ return dri2_create_image_from_fd(screen, width, height, fourcc,
-+ modifier, fds, num_fds,
-+ strides, offsets, NULL, loaderPrivate);
-+ #if 0
- return dri2_create_image_from_fd(screen, width, height, fourcc,
- DRM_FORMAT_MOD_INVALID, fds, num_fds,
- strides, offsets, NULL, loaderPrivate);
-+ #endif
- }
-
- static boolean
diff --git a/meta-raspberrypi/recipes-graphics/mesa/mesa_%.bbappend b/meta-raspberrypi/recipes-graphics/mesa/mesa_%.bbappend
index d3435e720d..eaa46f27b6 100644
--- a/meta-raspberrypi/recipes-graphics/mesa/mesa_%.bbappend
+++ b/meta-raspberrypi/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,10 +1,6 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
# DRI3 note:
# With oe-core commit 8509e2e1a87578882b71948ccef3b50ccf1228b3 dri3 is set
# as default. To state out clearly that Raspi needs dri3 and to avoid surprises
# in case oe-core changes this default, we set dri3 explicitly.
-
-SRC_URI_append_rpi = " file://0001-dri2-query-dma-buf-modifiers.patch "
-
PACKAGECONFIG_append_rpi = " gallium vc4 v3d kmsro ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11 dri3', '', d)}"
DRIDRIVERS_class-target_rpi = ""
diff --git a/meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend b/meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
index fba163219e..9574fa5b8a 100644
--- a/meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
+++ b/meta-raspberrypi/recipes-graphics/xorg-xserver/xserver-xorg_%.bbappend
@@ -1 +1,5 @@
OPENGL_PKGCONFIGS_rpi = "dri glx ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'dri3 xshmfence glamor', '', d)}"
+
+# when using userland graphic KHR/khrplatform.h is provided by userland but virtual/libgl is provided by mesa-gl where
+# we explicitly delete KHR/khrplatform.h since its already coming from userland package
+DEPENDS_append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'userland', d)}"