summaryrefslogtreecommitdiff
path: root/meta-raspberrypi/recipes-kernel/linux
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-10-16 18:13:56 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-10-16 18:13:58 +0300
commit5c4154ffa5fc7b63c57a909685a06a90a5b9c82c (patch)
tree158744d30b9970af4a50ecd384e511a8af77fb1c /meta-raspberrypi/recipes-kernel/linux
parenta9ff2b33c004367b3dbded5d54d7a272ed76f68f (diff)
downloadopenbmc-5c4154ffa5fc7b63c57a909685a06a90a5b9c82c.tar.xz
meta-raspberrypi: subtree update:0e9c32c816..6f85611576
Alex Gonzalez (1): linux-raspberrypi: Only deploy cmdline.txt for the main kernel Khem Raj (7): linux-firmware-rpidistro: Update to 20190114-1+rpt8 linux-raspberrypi_5.4.bb: Update to 5.4.69 raspberrypi-firmware: Update to 20201002 snapshot raspberrypi-tools: Update to latest snapshot as of 20200803 oeqa: Add 5.4 specific error messages to ignore list rpi-default-settings: Replace default parselogs with parselogs_rpi layer.conf: Add gatesgarth to LAYERSERIES_COMPAT Madhavan Krishnan (1): libcamera: Define packageconfig to enable rpi pipeline Martin Jansa (2): linux-raspberrypi-5.4: bump SRCREV to fix raspberrypi3-64 builds python3-rtimu: don't use trailing slash in S Murat Kilivan (1): linux-raspberrypi_5.4.bb: Add kernel-cache source Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I906081b851f3733a52c1899fe2b4e835021f6419
Diffstat (limited to 'meta-raspberrypi/recipes-kernel/linux')
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc14
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb5
-rw-r--r--meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc5
3 files changed, 15 insertions, 9 deletions
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
index f7dee7700d..3219a231f4 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi.inc
@@ -130,11 +130,13 @@ do_compile_append() {
}
do_deploy_append() {
- # Deploy cmdline.txt
- install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
- PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
- if [ ${PITFT} = "1" ]; then
- PITFT_PARAMS="fbcon=map:10 fbcon=font:VGA8x8"
+ # Deploy cmdline.txt only for the main kernel package
+ if [ ${KERNEL_PACKAGE_NAME} = "kernel" ]; then
+ install -d ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}
+ PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
+ if [ ${PITFT} = "1" ]; then
+ PITFT_PARAMS="fbcon=map:10 fbcon=font:VGA8x8"
+ fi
+ echo "${CMDLINE}${PITFT_PARAMS}" > ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/cmdline.txt
fi
- echo "${CMDLINE}${PITFT_PARAMS}" > ${DEPLOYDIR}/${BOOTFILES_DIR_NAME}/cmdline.txt
}
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
index 594694cbae..e057c3a744 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
@@ -1,7 +1,8 @@
-LINUX_VERSION ?= "5.4.64"
+LINUX_VERSION ?= "5.4.69"
LINUX_RPI_BRANCH ?= "rpi-5.4.y"
-SRCREV = "65caf603f3b1c43f4c92939f7fbb7149e054f486"
+SRCREV_machine = "31d364af258ff9754a1a9c7d8ea532da962797bd"
+SRCREV_meta = "5d52d9eea95fa09d404053360c2351b2b91b323b"
require linux-raspberrypi_5.4.inc
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc
index 232f8a97d8..9e8934a709 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.inc
@@ -1,7 +1,10 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:"
+KMETA = "kernel-meta"
+
SRC_URI = " \
- git://github.com/raspberrypi/linux.git;branch=${LINUX_RPI_BRANCH} \
+ git://github.com/raspberrypi/linux.git;name=machine;branch=${LINUX_RPI_BRANCH} \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.4;destsuffix=${KMETA} \
"
SRC_URI_remove = "file://rpi-kernel-misc.cfg"