summaryrefslogtreecommitdiff
path: root/meta-raspberrypi
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-05-27 16:04:48 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-05-27 16:12:32 +0300
commit67107382f0ac2ad2ff42819a3d3189dc838a7ed5 (patch)
tree65efc3f2b911d71da8e23e999b3f2b0bb976354f /meta-raspberrypi
parentd7eca3aaccf58555fa5619465140d3b71204720c (diff)
downloadopenbmc-67107382f0ac2ad2ff42819a3d3189dc838a7ed5.tar.xz
subtree updates
meta-raspberrypi: b601818301..11209a4981: sss22213 (1): recipes-bsp: Add support for Raspberry Pi HD quality camera poky: 05a8aad57c..fd33741e27: Alexander Kanavin (1): bitbake: fetch2/wget: when checking latest versions, consider all numerical directories Bastian Krause (1): ccache: add packageconfig docs option Michael Halstead (1): uninative: Upgrade to 3.2 (gcc11 support) Richard Purdie (19): bitbake: server/process: Handle error in heartbeat funciton in OOM case glibc: Document and whitelist CVE-2019-1010022-25 qemu: Exclude CVE-2017-5957 from cve-check qemu: Exclude CVE-2007-0998 from cve-check qemu: Exclude CVE-2018-18438 from cve-check jquery: Exclude CVE-2007-2379 from cve-check logrotate: Exclude CVE-2011-1548,1549,1550 from cve-check openssh: Exclude CVE-2007-2768 from cve-check openssh: Exclude CVE-2008-3844 from cve-check unzip: Exclude CVE-2008-0888 from cve-check cpio: Exclude CVE-2010-4226 from cve-check ghostscript: Exclude CVE-2013-6629 from cve-check bluez: Exclude CVE-2020-12352 CVE-2020-24490 from cve-check tiff: Exclude CVE-2015-7313 from cve-check coreutils: Exclude CVE-2016-2781 from cve-check librsvg: Exclude CVE-2018-1000041 from cve-check avahi: Exclude CVE-2021-26720 from cve-check glibc: Add 8GB VM usage cap for usermode test suite sstate: Handle manifest 'corruption' issue Robert P. J. Day (2): image.bbclass: fix comment "pacackages" -> "packages" meta/lib/oe/rootfs.py: Fix typo "Restoreing" -> "Restoring" Ross Burton (3): libnotify: whitelist CVE-2013-7381 (specific to the NodeJS bindings) builder: whitelist CVE-2008-4178 (a different builder) cups: whitelist CVE-2021-25317 Tony Tascioglu (3): libxml2: fix CVE-2021-3517 libxml2: fix CVE-2021-3516 libxml2: fix CVE-2021-3537 meta-openembedded: bbe3855ec7..cf5bd6a830: Andreas Müller (2): zsh: reduce priority slightly to avoid conflict with bash xfce4-settings: upgrade 4.16.0 -> 4.16.1 Khem Raj (3): aom: Match the name for AOM-Patent-License-1.0 libdevmapper,lvm2: Do not inherit license python3-jinja2_2.%.bbappend: Delete Saul Wold (2): tbb: Disable PPC as COMPATIBLE_MACHINE packagegroup-meta-oe: conditional remove tbb for powerpc Silcet (1): ufw: fix python shebang zangrc (3): fetchmail: upgrade 6.4.18 -> 6.4.19 openvpn: upgrade 2.5.1 -> 2.5.2 wireshark: upgrade 3.4.4 -> 3.4.5 Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I84a4b5733ff5d04c39580402b64c5c649ac991a9
Diffstat (limited to 'meta-raspberrypi')
-rw-r--r--meta-raspberrypi/conf/machine/include/rpi-base.inc1
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb2
-rw-r--r--meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb8
3 files changed, 10 insertions, 1 deletions
diff --git a/meta-raspberrypi/conf/machine/include/rpi-base.inc b/meta-raspberrypi/conf/machine/include/rpi-base.inc
index 77cada7436..a800078473 100644
--- a/meta-raspberrypi/conf/machine/include/rpi-base.inc
+++ b/meta-raspberrypi/conf/machine/include/rpi-base.inc
@@ -31,6 +31,7 @@ RPI_KERNEL_DEVICETREE_OVERLAYS ?= " \
overlays/justboom-digi.dtbo \
overlays/i2c-rtc.dtbo \
overlays/imx219.dtbo \
+ overlays/imx477.dtbo \
overlays/iqaudio-dac.dtbo \
overlays/iqaudio-dacplus.dtbo \
overlays/mcp2515-can0.dtbo \
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb
index 40a9949a14..3ebd1e61c2 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-cmdline.bb
@@ -13,6 +13,8 @@ CMDLINE_SERIAL ?= "${@oe.utils.conditional("ENABLE_UART", "1", "console=serial0,
CMDLINE_CMA ?= "${@oe.utils.conditional("RASPBERRYPI_CAMERA_V2", "1", "cma=64M", "", d)}"
+CMDLINE_CMA ?= "${@oe.utils.conditional("RASPBERRYPI_HD_CAMERA", "1", "cma=64M", "", d)}"
+
CMDLINE_PITFT ?= "${@bb.utils.contains("MACHINE_FEATURES", "pitft", "fbcon=map:10 fbcon=font:VGA8x8", "", d)}"
# Add the kernel debugger over console kernel command line option if enabled
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index c4b441182b..052206acfa 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -189,10 +189,16 @@ do_deploy() {
# Choose Camera Sensor to be used, default imx219 sensor
if [ "${RASPBERRYPI_CAMERA_V2}" = "1" ]; then
- echo "# Enable Sony RaspberryPi Camera" >> $CONFIG
+ echo "# Enable Sony RaspberryPi Camera(imx219)" >> $CONFIG
echo "dtoverlay=imx219" >> $CONFIG
fi
+ # Choose Camera Sensor to be used, default imx477 sensor
+ #if [ "${RASPBERRYPI_HD_CAMERA}" = "1" ]; then
+ # echo "# Enable Sony RaspberryPi Camera(imx477)" >> $CONFIG
+ # echo "dtoverlay=imx477" >> $CONFIG
+ #fi
+
# Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then
echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> $CONFIG