summaryrefslogtreecommitdiff
path: root/meta-security/recipes-mac
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-01-20 20:06:23 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-01-20 20:06:26 +0300
commit53961c2d8a97d0f9e5a90c17ca48380657e79c3e (patch)
tree0f30b66a917f31dfd698059e03d254464b48c564 /meta-security/recipes-mac
parentcbf46010eab661117b0225bdb30fcf565c1d8b3c (diff)
downloadopenbmc-53961c2d8a97d0f9e5a90c17ca48380657e79c3e.tar.xz
meta-security: subtree update:a85fbe980e..c20b35b527
Anton Antonov (1): Parsec service. Update PACKAGECONFIG definitions and README.md Armin Kuster (20): python3-fail2ban: fix build failure and cleanup meta-parsec/README: remove rust layer req. opendnssec: blacklist do to ldns being blacklisted apparmor: Add a python 3.10 compatability patch tpm2-tools: update to 5.2 openssl-tpm-engine: fix build issue with openssl 3 tpm2-openssl: add new pkg tpm2-pkcs11: update to 1.7.0 recipes: Update SRC_URI branch and protocols sssd: Create /var/log/sssd in runtime bastille: Create /var/log/Bastille in runtime python3-fail2ban: remove /run tpm2-pkcs11: update to 1.7.0 libest: does not build with openssl 3.x clamav: fix useradd warning python3-fail2ban: update to tip tpm2-pkcs11: backport openssl 3.x build fixes packagegroup-security-tpm2: drop ibmswtpm2 meta-integrity: drop strongswan bbappends meta-tpm: drop strongswan bbappends Kai Kang (2): sssd: re-package to fix QA issues apparmor: fix warning of remove operator combined with += Kristian Klausen (2): swtpm: update to 0.6.1 dm-verity-img.bbclass: Fix wrong override syntax for CONVERSION_DEPENDS Liwei Song (1): recipes-security/chipsec: platform security assessment framework Stefan Mueller-Klieser (1): tpm2-tss: fix fapi package config Yi Zhao (2): openssl-tpm-engine: fix warning for append operator combined with += meta-parsec/README.md: fix for append operator combined with += Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I2156e47cf3f4f45daa2b60a73e3b46be3b6a86c0
Diffstat (limited to 'meta-security/recipes-mac')
-rw-r--r--meta-security/recipes-mac/AppArmor/apparmor_3.0.1.bb6
-rw-r--r--meta-security/recipes-mac/AppArmor/files/py3_10_fixup.patch35
-rw-r--r--meta-security/recipes-mac/smack/smack_1.3.1.bb2
3 files changed, 39 insertions, 4 deletions
diff --git a/meta-security/recipes-mac/AppArmor/apparmor_3.0.1.bb b/meta-security/recipes-mac/AppArmor/apparmor_3.0.1.bb
index dca53a3858..818be155c0 100644
--- a/meta-security/recipes-mac/AppArmor/apparmor_3.0.1.bb
+++ b/meta-security/recipes-mac/AppArmor/apparmor_3.0.1.bb
@@ -16,15 +16,15 @@ DEPENDS = "bison-native apr gettext-native coreutils-native swig-native"
SRC_URI = " \
git://gitlab.com/apparmor/apparmor.git;protocol=https;branch=apparmor-3.0 \
file://run-ptest \
- file://disable_perl_h_check.patch \
file://crosscompile_perl_bindings.patch \
file://0001-Makefile.am-suppress-perllocal.pod.patch \
file://0001-Revert-profiles-Update-make-check-to-select-tools-ba.patch \
file://0001-Makefile-fix-hardcoded-installation-directories.patch \
file://0001-rc.apparmor.debian-add-missing-functions.patch \
+ file://py3_10_fixup.patch \
"
-SRCREV = "b0f08aa9d678197b8e3477c2fbff790f50a1de5e"
+SRCREV = "b23de501807b8b5793e9654da8688b5fd3281154"
S = "${WORKDIR}/git"
PARALLEL_MAKE = ""
@@ -168,7 +168,7 @@ RDEPENDS:${PN}:libc-glibc += "glibc-utils"
# Add coreutils and findutils only if sysvinit scripts are in use
RDEPENDS:${PN} += "${@["coreutils findutils", ""][(d.getVar('VIRTUAL-RUNTIME_init_manager') == 'systemd')]} ${@bb.utils.contains('PACKAGECONFIG','python','python3-core python3-modules','', d)}"
-RDEPENDS:${PN}:remove += "${@bb.utils.contains('PACKAGECONFIG','perl','','perl', d)}"
+RDEPENDS:${PN}:remove = "${@bb.utils.contains('PACKAGECONFIG','perl','','perl', d)}"
RDEPENDS:${PN}-ptest += "perl coreutils dbus-lib bash"
INSANE_SKIP:${PN} = "ldflags"
diff --git a/meta-security/recipes-mac/AppArmor/files/py3_10_fixup.patch b/meta-security/recipes-mac/AppArmor/files/py3_10_fixup.patch
new file mode 100644
index 0000000000..05f84600a3
--- /dev/null
+++ b/meta-security/recipes-mac/AppArmor/files/py3_10_fixup.patch
@@ -0,0 +1,35 @@
+m4/ax_python_devel.m4: do not check for distutils
+
+With py 3.10 this prints a deprecation warning which is
+taken as an error. Upstream should rework the code to not
+use distuils.
+
+Upstream-Status: Inappropriate [needs a proper fix upstream]
+Signed-off-by: Armin Kuster <akuster808@gmail.com>
+
+Index: git/libraries/libapparmor/m4/ac_python_devel.m4
+===================================================================
+--- git.orig/libraries/libapparmor/m4/ac_python_devel.m4
++++ git/libraries/libapparmor/m4/ac_python_devel.m4
+@@ -66,21 +66,6 @@ variable to configure. See ``configure -
+ fi
+
+ #
+- # Check if you have distutils, else fail
+- #
+- AC_MSG_CHECKING([for the distutils Python package])
+- ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
+- if test -z "$ac_distutils_result"; then
+- AC_MSG_RESULT([yes])
+- else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([cannot import Python module "distutils".
+-Please check your Python installation. The error was:
+-$ac_distutils_result])
+- PYTHON_VERSION=""
+- fi
+-
+- #
+ # Check for Python include path
+ #
+ AC_MSG_CHECKING([for Python include path])
diff --git a/meta-security/recipes-mac/smack/smack_1.3.1.bb b/meta-security/recipes-mac/smack/smack_1.3.1.bb
index 6c2f041084..79a8f5a0cd 100644
--- a/meta-security/recipes-mac/smack/smack_1.3.1.bb
+++ b/meta-security/recipes-mac/smack/smack_1.3.1.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRCREV = "4a102c7584b39ce693995ffb65e0918a9df98dd8"
SRC_URI = " \
- git://github.com/smack-team/smack.git \
+ git://github.com/smack-team/smack.git;branch=master;protocol=https \
file://smack_generator_make_fixup.patch \
file://run-ptest"