summaryrefslogtreecommitdiff
path: root/meta-xilinx/meta-xilinx-bsp/recipes-bsp
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2021-01-30 00:55:05 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-01-30 19:33:11 +0300
commitc60845c87403beb867c541f4271d05287f38a985 (patch)
tree077e305e62d0ef0acb5e06b22fab88fb087d5c4d /meta-xilinx/meta-xilinx-bsp/recipes-bsp
parent7c9805840d4a9d4c02c6a18e5fbfef48bd621fec (diff)
downloadopenbmc-c60845c87403beb867c541f4271d05287f38a985.tar.xz
meta-xilinx: subtree update:a9025136f5..eb4ba06eb1
David Roman (1): picozed-zynq7.dts: add marvell,88e1510 to eth phy Jaewon Lee (3): xilinx-board.inc: fixing BOARD_ARCH and BOARDVARIANT_ARCH names Adding BOARD and BOARD_VARIANT level hierarchy ultra96: Using BOARD level hiearchy for ultra96 overrides Madhurkiran Harikrishnan (1): weston: Update the weston patches to comply with weston-9.0 Philip Balister (2): u-boot-xlnx: Fix build error by applying patch from upstream u-boot. linux-xlnx: Fix build with patch from upstream kernel for gcc-10. Raju Kumar Pothuraju (1): linux-xlnx.inc: Update overlay config fragments Sai Hari Chandana Kalluri (4): Update LICENSE_CHECKSUM for kernel-module-hdmi zcu102-zynqmp.conf: Fix qemuboot for zcu102-zynqmp Cleanup QB_MACHINE for xilinx machines qemu-xilinx: Fix patch puzz warning during do_patch Varalaxmi Bingi (1): meta-xilinx-bsp: Move uboot-device-tree to meta-xilinx-tools layer Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I2c1c51b9988cb36185f3218075ea007c14f82ff8
Diffstat (limited to 'meta-xilinx/meta-xilinx-bsp/recipes-bsp')
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/device-tree/files/picozed-zynq7.dts2
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/files/0001-Remove-redundant-YYLOC-global-declaration.patch28
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2020.2.bb4
-rw-r--r--meta-xilinx/meta-xilinx-bsp/recipes-bsp/uboot-device-tree/uboot-device-tree.bb78
4 files changed, 33 insertions, 79 deletions
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/device-tree/files/picozed-zynq7.dts b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/device-tree/files/picozed-zynq7.dts
index 4ec64f5e29..6f9b653ab9 100644
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/device-tree/files/picozed-zynq7.dts
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/device-tree/files/picozed-zynq7.dts
@@ -34,7 +34,7 @@
phy-handle = <&ethernet_phy>;
ethernet_phy: ethernet-phy@0 {
- compatible = "marvell,88e1512";
+ compatible = "marvell,88e1512", "marvell,88e1510";
device_type = "ethernet-phy";
reg = <0>;
};
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/files/0001-Remove-redundant-YYLOC-global-declaration.patch b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/files/0001-Remove-redundant-YYLOC-global-declaration.patch
new file mode 100644
index 0000000000..7091098ca6
--- /dev/null
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/files/0001-Remove-redundant-YYLOC-global-declaration.patch
@@ -0,0 +1,28 @@
+From 8127b19aa42ccfb3faae1173a12b3eb0cebf8941 Mon Sep 17 00:00:00 2001
+From: Peter Robinson <pbrobinson@gmail.com>
+Date: Thu, 30 Jan 2020 09:37:15 +0000
+Subject: [PATCH] Remove redundant YYLOC global declaration
+
+Same as the upstream fix for building dtc with gcc 10.
+
+Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
+State: upstream (e33a814e772cdc36436c8c188d8c42d019fda639)
+---
+ scripts/dtc/dtc-lexer.l | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/scripts/dtc/dtc-lexer.l b/scripts/dtc/dtc-lexer.l
+index fd825ebba6..24af549977 100644
+--- a/scripts/dtc/dtc-lexer.l
++++ b/scripts/dtc/dtc-lexer.l
+@@ -38,7 +38,6 @@ LINECOMMENT "//".*\n
+ #include "srcpos.h"
+ #include "dtc-parser.tab.h"
+
+-YYLTYPE yylloc;
+ extern bool treesource_error;
+
+ /* CAUTION: this will stop working if we ever use yyless() or yyunput() */
+--
+2.29.2
+
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2020.2.bb b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2020.2.bb
index 9e289a0894..95c7254c6a 100644
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2020.2.bb
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2020.2.bb
@@ -7,6 +7,10 @@ SRCREV ?= "bb4660c33aa7ea64f78b2682bf0efd56765197d6"
include u-boot-xlnx.inc
include u-boot-spl-zynq-init.inc
+# Patch required for latest gcc and 2020.2 version of u-boot-xlnx
+# This will be removed once the SRCREV above has been updated to include this change
+SRC_URI += " file://0001-Remove-redundant-YYLOC-global-declaration.patch"
+
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://README;beginline=1;endline=4;md5=744e7e3bb0c94b4b9f6b3db3bf893897"
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/uboot-device-tree/uboot-device-tree.bb b/meta-xilinx/meta-xilinx-bsp/recipes-bsp/uboot-device-tree/uboot-device-tree.bb
deleted file mode 100644
index 885dce8c8d..0000000000
--- a/meta-xilinx/meta-xilinx-bsp/recipes-bsp/uboot-device-tree/uboot-device-tree.bb
+++ /dev/null
@@ -1,78 +0,0 @@
-SUMMARY = "Xilinx BSP u-boot device trees"
-DESCRIPTION = "Xilinx BSP u-boot device trees from within layer."
-SECTION = "bsp"
-
-LICENSE = "MIT & GPLv2"
-LIC_FILES_CHKSUM = " \
- file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
- file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
- "
-
-inherit devicetree xsctdt xsctyaml
-
-
-REPO ??= "git://github.com/xilinx/device-tree-xlnx.git;protocol=https"
-BRANCH ??= "master"
-BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH') != '']}"
-SRC_URI = "${REPO};${BRANCHARG}"
-
-PROVIDES = "virtual/uboot-dtb"
-
-S = "${WORKDIR}/git"
-B = "${WORKDIR}/build"
-
-SRCREV ??= "bc8445833318e9320bf485ea125921eecc3dc97a"
-PV = "xilinx+git${SRCPV}"
-
-PACKAGE_ARCH ?= "${MACHINE_ARCH}"
-
-COMPATIBLE_MACHINE ?= "^$"
-COMPATIBLE_MACHINE_zynqmp = ".*"
-COMPATIBLE_MACHINE_zynq = ".*"
-COMPATIBLE_MACHINE_versal = ".*"
-
-XSCTH_BUILD_CONFIG ?= ""
-
-DT_FILES_PATH = "${XSCTH_WS}/${XSCTH_PROJ}"
-DT_INCLUDE_append = " ${WORKDIR}"
-DT_PADDING_SIZE = "0x1000"
-
-UBOOT_DTS ?= ""
-XSCTH_MISC = " -hdf_type ${HDF_EXT}"
-XSCTH_APP = "device-tree"
-YAML_DT_BOARD_FLAGS_zynqmp-generic ?= ""
-YAML_DT_BOARD_FLAGS_versal-generic ?= ""
-YAML_DT_BOARD_FLAGS_zynq-generic ?= ""
-UBOOT_DTS_NAME = "u-boot"
-DTB_FILE = "u-boot.dtb"
-
-do_configure[dirs] += "${DT_FILES_PATH}"
-SRC_URI_append = "${@" ".join(["file://%s" % f for f in (d.getVar('UBOOT_DTS') or "").split()])}"
-
-do_configure_prepend () {
- if [ ! -z "${UBOOT_DTS}" ]; then
- for f in ${UBOOT_DTS}; do
- cp -rf ${WORKDIR}/${f} ${DT_FILES_PATH}/
- done
- return
- fi
-}
-
-
-#Both linux dtb and uboot dtb are installing
-#system-top.dtb for uboot env recipe while do_prepare_recipe_sysroot
-#moving system-top.dts to othername.
-do_compile_prepend() {
- import shutil
-
- listpath = d.getVar("DT_FILES_PATH")
- try:
- os.remove(os.path.join(listpath, "system.dts"))
- shutil.move(os.path.join(listpath, "system-top.dts"), os.path.join(listpath, d.getVar("UBOOT_DTS_NAME") + ".dts"))
- except OSError:
- pass
-}
-
-do_deploy() {
- install -Dm 0644 ${B}/${UBOOT_DTS_NAME}.dtb ${DEPLOYDIR}/${UBOOT_DTS_NAME}.dtb
-}