summaryrefslogtreecommitdiff
path: root/import-layers/meta-openembedded/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-openembedded/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb')
-rw-r--r--import-layers/meta-openembedded/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/import-layers/meta-openembedded/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb b/import-layers/meta-openembedded/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
index a2747c3508..25166ab580 100644
--- a/import-layers/meta-openembedded/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
+++ b/import-layers/meta-openembedded/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://github.com/kkaempf/cmpi-bindings"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=b19ee058d2d5f69af45da98051d91064"
SECTION = "Development/Libraries"
-DEPENDS = "swig-native python sblim-cmpi-devel"
+DEPENDS = "swig-native python3 sblim-cmpi-devel"
SRC_URI = "git://github.com/kkaempf/cmpi-bindings.git;protocol=http \
file://cmpi-bindings-0.4.17-no-ruby-perl.patch \
@@ -13,19 +13,18 @@ SRC_URI = "git://github.com/kkaempf/cmpi-bindings.git;protocol=http \
file://0001-Modify-cmakelist.patch \
file://0001-Fix-error.patch \
file://0001-fix-the-build-error-when-python-3.0.patch \
+ file://0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch \
"
SRCREV = "62f60e065aa1b901f826e4f530c0573ae32d065e"
S = "${WORKDIR}/git"
-inherit cmake pythonnative
+inherit cmake python3native
EXTRA_OECMAKE = "-DLIB='${baselib}' \
-DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION}"
do_configure_prepend() {
- export HOST_SYS=${HOST_SYS}
- export BUILD_SYS=${BUILD_SYS}
export STAGING_LIBDIR=${STAGING_LIBDIR}
export STAGING_INCDIR=${STAGING_INCDIR}
export ENV_INSTALL_PATH=${PYTHON_SITEPACKAGES_DIR}