summaryrefslogtreecommitdiff
path: root/import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-six.inc
diff options
context:
space:
mode:
Diffstat (limited to 'import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-six.inc')
-rw-r--r--import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-six.inc6
1 files changed, 4 insertions, 2 deletions
diff --git a/import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-six.inc b/import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-six.inc
index 408c60e88e..e33c01ded3 100644
--- a/import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-six.inc
+++ b/import-layers/meta-openembedded/meta-python/recipes-devtools/python/python-six.inc
@@ -6,11 +6,13 @@ SRC_URI[md5sum] = "34eed507548117b2ab523ab14b2f8b55"
SRC_URI[sha256sum] = "105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a"
do_compile_append() {
- export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
${PYTHON} setup.py -q bdist_egg --dist-dir ./
}
do_install_append() {
install -m 0644 ${S}/*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/
}
-RDEPENDS_${PN} += "python-io"
+RDEPENDS_${PN} += "${PYTHON_PN}-io"
+
+BBCLASSEXTEND = "native nativesdk"
+