summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/psu.json25
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb6
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/psu.json b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/psu.json
new file mode 100644
index 0000000000..2dcefab2b3
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/psu.json
@@ -0,0 +1,25 @@
+{
+ "inventoryPMBusAccessType": "HwmonDeviceDebug",
+ "fruConfigs": [
+ {
+ "propertyName": "PartNumber",
+ "fileName": "part_number",
+ "interface": "xyz.openbmc_project.Inventory.Decorator.Asset"
+ },
+ {
+ "propertyName": "SerialNumber",
+ "fileName": "serial_number",
+ "interface": "xyz.openbmc_project.Inventory.Decorator.Asset"
+ },
+ {
+ "propertyName": "Model",
+ "fileName": "ccin",
+ "interface": "xyz.openbmc_project.Inventory.Decorator.Asset"
+ },
+ {
+ "propertyName": "Version",
+ "fileName": "fw_version",
+ "interface": "xyz.openbmc_project.Software.Version"
+ }
+ ]
+}
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
index 49fe344dc0..2625bfc387 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
@@ -11,6 +11,7 @@ inherit pythonnative
require ${PN}.inc
S = "${WORKDIR}/git"
+SRC_URI += "file://psu.json"
DEPENDS += " \
phosphor-logging \
@@ -24,6 +25,11 @@ DEPENDS += " \
EXTRA_OEMESON += "-Ducd90160-yaml=${STAGING_DIR_HOST}${datadir}/power-sequencer/ucd90160.yaml"
+do_install_append(){
+ install -D ${WORKDIR}/psu.json ${D}${datadir}/phosphor-power/psu.json
+}
+FILES_${PN} += "${datadir}/phosphor-power/psu.json"
+
CHASSIS_ON_TGT = "obmc-chassis-poweron@0.target"
SEQ_MONITOR_SVC = "pseq-monitor.service"
SEQ_MONITOR_FMT = "../${SEQ_MONITOR_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_MONITOR_SVC}"