summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/meta-witherspoon')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb23
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend2
2 files changed, 24 insertions, 1 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb
new file mode 100644
index 0000000000..2281192fe4
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/wistron-ipmi-oem_git.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Wistron OEM commands"
+DESCRIPTION = "Wistron OEM commands"
+HOMEPAGE = "https://github.com/openbmc/wistron-ipmi-oem"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "phosphor-ipmi-host"
+DEPENDS += "autoconf-archive-native"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://github.com/openbmc/wistron-ipmi-oem"
+SRCREV = "44cee319dd113335a7885a1ff63a287dc7706682"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+
+HOSTIPMI_PROVIDER_LIBRARY += "libwistronoem.so"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index 56d1bc7df3..972dacf454 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -19,7 +19,7 @@ RDEPENDS_${PN}-inventory_append_mihawk = " openpower-fru-vpd openpower-occ-contr
RDEPENDS_${PN}-fan-control_append_ibm-ac-server = " witherspoon-fan-watchdog"
RDEPENDS_${PN}-extras_append_ibm-ac-server = " ${POWER_SERVICE_PACKAGES_AC_SERVER} witherspoon-power-supply-sync phosphor-webui"
RDEPENDS_${PN}-extras_append_rainier = " ${POWER_SERVICE_PACKAGES_RAINIER} phosphor-webui"
-RDEPENDS_${PN}-extras_append_mihawk = " phosphor-webui phosphor-image-signing"
+RDEPENDS_${PN}-extras_append_mihawk = " phosphor-webui phosphor-image-signing wistron-ipmi-oem"
RDEPENDS_${PN}-extras_remove_rainier = "obmc-ikvm liberation-fonts uart-render-controller"
RDEPENDS_${PN}-extras_remove_swift = "obmc-ikvm"
RDEPENDS_${PN}-extras_remove_witherspoon-tacoma = "obmc-ikvm liberation-fonts uart-render-controller"