summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm/recipes-phosphor')
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend4
-rw-r--r--meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/rainier/rainier-1s4u/config.json86
2 files changed, 90 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
index efbdea1f3e..8817592d47 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
@@ -3,6 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
SRC_URI_witherspoon = "file://config.json"
SRC_URI_rainier = "file://rainier-2u/config.json \
file://rainier-4u/config.json \
+ file://rainier-1s4u/config.json \
file://everest/config.json \
"
@@ -14,8 +15,10 @@ do_install_rainier() {
# Install Rainier-2U/4U fan presence config files
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
+ install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
install -m 0644 ${WORKDIR}/rainier-2u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
install -m 0644 ${WORKDIR}/rainier-4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
+ install -m 0644 ${WORKDIR}/rainier-1s4u/config.json ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/
# Install Everest fan presence config file
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,everest/
@@ -28,4 +31,5 @@ FILES_${PN}_remove_witherspoon = "${presence_datadir}/config.yaml"
FILES_${PN}_remove_rainier = "${presence_datadir}/config.yaml"
FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
+FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/rainier/rainier-1s4u/config.json b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/rainier/rainier-1s4u/config.json
new file mode 100644
index 0000000000..cb9eb70dec
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config/rainier/rainier-1s4u/config.json
@@ -0,0 +1,86 @@
+[
+ {
+ "name": "fan0",
+ "path": "/system/chassis/motherboard/fan0",
+ "methods": [
+ {
+ "type": "gpio",
+ "key": 6,
+ "physpath": "/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a400.i2c-bus/i2c-7/7-0061",
+ "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
+ },
+ {
+ "type": "tach",
+ "sensors": [
+ "fan0_0"
+ ]
+ }
+ ],
+ "rpolicy": {
+ "type": "anyof"
+ }
+ },
+ {
+ "name": "fan1",
+ "path": "/system/chassis/motherboard/fan1",
+ "methods": [
+ {
+ "type": "gpio",
+ "key": 7,
+ "physpath": "/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a400.i2c-bus/i2c-7/7-0061",
+ "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
+ },
+ {
+ "type": "tach",
+ "sensors": [
+ "fan1_0"
+ ]
+ }
+ ],
+ "rpolicy": {
+ "type": "anyof"
+ }
+ },
+ {
+ "name": "fan2",
+ "path": "/system/chassis/motherboard/fan2",
+ "methods": [
+ {
+ "type": "gpio",
+ "key": 8,
+ "physpath": "/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a400.i2c-bus/i2c-7/7-0061",
+ "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
+ },
+ {
+ "type": "tach",
+ "sensors": [
+ "fan2_0"
+ ]
+ }
+ ],
+ "rpolicy": {
+ "type": "anyof"
+ }
+ },
+ {
+ "name": "fan3",
+ "path": "/system/chassis/motherboard/fan3",
+ "methods": [
+ {
+ "type": "gpio",
+ "key": 9,
+ "physpath": "/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a400.i2c-bus/i2c-7/7-0061",
+ "devpath": "/dev/input/by-path/platform-gpio-keys-polled-event"
+ },
+ {
+ "type": "tach",
+ "sensors": [
+ "fan3_0"
+ ]
+ }
+ ],
+ "rpolicy": {
+ "type": "anyof"
+ }
+ }
+]