summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/conf/layer.conf3
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb3
-rw-r--r--meta-ibm/meta-palmetto/recipes-phosphor/leds/palmetto-led-manager-config-native.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-fru-read-inventory-native.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-sel-native.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb3
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/logging/romulus-phosphor-logging-callouts-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb3
-rw-r--r--meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb3
21 files changed, 43 insertions, 20 deletions
diff --git a/meta-ibm/conf/layer.conf b/meta-ibm/conf/layer.conf
index 72351f158c..434f616956 100644
--- a/meta-ibm/conf/layer.conf
+++ b/meta-ibm/conf/layer.conf
@@ -8,3 +8,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "ibm-layer"
BBFILE_PATTERN_ibm-layer = ""
LAYERSERIES_COMPAT_ibm-layer = "sumo"
+
+# Provide a variable that points the base of the ibm layer.
+IBMBASE = '${@os.path.normpath("${LAYERDIR}/")}'
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb b/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb
index 2b5348a9f0..8e328d846f 100644
--- a/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/ipmi/palmetto-ipmi-inventory-map-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Palmetto IPMI to DBus Inventory mapping."
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-ipmi-fru
SRC_URI += "file://config.yaml"
diff --git a/meta-ibm/meta-palmetto/recipes-phosphor/leds/palmetto-led-manager-config-native.bb b/meta-ibm/meta-palmetto/recipes-phosphor/leds/palmetto-led-manager-config-native.bb
index d633fd980f..a7e8c6b74d 100644
--- a/meta-ibm/meta-palmetto/recipes-phosphor/leds/palmetto-led-manager-config-native.bb
+++ b/meta-ibm/meta-palmetto/recipes-phosphor/leds/palmetto-led-manager-config-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Phosphor LED Group Management for Palmetto"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
PROVIDES += "virtual/phosphor-led-manager-config-native"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb b/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
index 252d2cbfcc..ca45a1eb37 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
@@ -1,8 +1,9 @@
SUMMARY = "Romulus AVSBus control"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
RDEPENDS_${PN} += "i2c-tools bash"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb b/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
index e23bdd0779..ba38b87692 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/chassis/vrm-control.bb
@@ -1,9 +1,10 @@
SUMMARY = "Romulus VRM Overrides"
DESCRIPTION = "Sets Rolumus VRMs to custom voltages"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
RDEPENDS_${PN} += "i2c-tools bash"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb b/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
index 7267ee3d54..90513b4d1a 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/gpio/id-button.bb
@@ -1,8 +1,9 @@
SUMMARY = "Romulus ID Button pressed application"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
DEPENDS += "virtual/obmc-gpio-monitor"
RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-fru-read-inventory-native.bb b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-fru-read-inventory-native.bb
index 5551200e1c..6f416c1a71 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-fru-read-inventory-native.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-fru-read-inventory-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Romulus inventory map for phosphor-ipmi-host"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-ipmi-host
SRC_URI += "file://config.yaml"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb
index c418498f5a..c0620ff5d1 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-map-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Romulus IPMI to DBus Inventory mapping."
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-ipmi-fru
SRC_URI += "file://config.yaml"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-sel-native.bb b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-sel-native.bb
index 93907c8587..60904656f5 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-sel-native.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/ipmi/romulus-ipmi-inventory-sel-native.bb
@@ -1,9 +1,10 @@
SUMMARY = "Inventory to Sensor config for Romulus"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
inherit phosphor-ipmi-host
-inherit obmc-phosphor-license
PROVIDES += "virtual/phosphor-ipmi-inventory-sel"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb b/meta-ibm/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb
index 3c7adaaac7..9b511e015e 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/leds/romulus-led-manager-config-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Phosphor LED Group Management for Romulus"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
PROVIDES += "virtual/phosphor-led-manager-config-native"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/logging/romulus-phosphor-logging-callouts-native.bb b/meta-ibm/meta-romulus/recipes-phosphor/logging/romulus-phosphor-logging-callouts-native.bb
index 375213957c..a6fd5b1f9e 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/logging/romulus-phosphor-logging-callouts-native.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/logging/romulus-phosphor-logging-callouts-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Romulus inventory map for phosphor-ipmi-host"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-logging
SRC_URI += "file://callouts.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb
index a09cdc750e..5abe1be1fa 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb
@@ -1,8 +1,9 @@
SUMMARY = "Witherspoon AVSBus control"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
RDEPENDS_${PN} += "i2c-tools"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
index d05e67fb9c..36416e949d 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vrm-control.bb
@@ -1,9 +1,10 @@
SUMMARY = "Witherspoon VRM Overrides"
DESCRIPTION = "Sets Witherspoon VRMs to custom voltages"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit obmc-phosphor-systemd
-inherit obmc-phosphor-license
RDEPENDS_${PN} += "i2c-tools bash"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy-native.bb
index c478e12b77..e855754c56 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy-native.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/events/witherspoon-events-policy-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Event policy for Witherspoon"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-dbus-monitor
SRC_URI += "file://config.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb
index b7da45c01f..070fceeecf 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-policy-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Fan policy for Witherspoon"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-dbus-monitor
SRC_URI += "file://air-cooled.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb
index c09b9df24e..357de9516e 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-fan-watchdog.bb
@@ -1,7 +1,8 @@
SUMMARY = "Witherspoon fan watchdog services"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb
index 39831cf86b..d53b4146fa 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/witherspoon-thermal-policy-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Thermal policy for Witherspoon"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-dbus-monitor
SRC_URI += "file://thermal-policy.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb
index 6efde485fd..80e6e6de5b 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/inventory/inventory-cleanup-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Copy Witherspoon inventory cleanup yaml for inventory manager"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-inventory-manager
SRC_URI += "file://inventory-cleanup.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb
index 4d234c1993..563f80e30a 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-policy-native.bb
@@ -1,8 +1,9 @@
SUMMARY = "Power supply policy for Witherspoon"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit native
-inherit obmc-phosphor-license
inherit phosphor-dbus-monitor
SRC_URI += "file://power-supply-policy.yaml"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
index b0903e7147..ea7804bcdd 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-power-supply-sync.bb
@@ -1,8 +1,9 @@
SUMMARY = "Witherspoon Power Supply Sync"
DESCRIPTION = "Synchronizes the power supplies' INPUT_HISTORY data"
PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
diff --git a/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb b/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb
index 2768caf576..381bef419e 100644
--- a/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb
+++ b/meta-ibm/recipes-phosphor/dbus/ibm-dbus-interfaces-mapper-config-native.bb
@@ -1,10 +1,11 @@
SUMMARY="Add /com/ibm namespace to phosphor-mapper"
DESCRIPTION="Add the /com/ibm path namespace and \
com.ibm interface prefix to the mapper watch list."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
inherit phosphor-mapper
inherit native
-inherit obmc-phosphor-license
PHOSPHOR_MAPPER_SERVICE_append = " com.ibm"
PHOSPHOR_MAPPER_INTERFACE_append = " com.ibm"