summaryrefslogtreecommitdiff
path: root/meta-ibs/meta-common/recipes-bsp/u-boot/libubootenv_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibs/meta-common/recipes-bsp/u-boot/libubootenv_%.bbappend')
-rw-r--r--meta-ibs/meta-common/recipes-bsp/u-boot/libubootenv_%.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-ibs/meta-common/recipes-bsp/u-boot/libubootenv_%.bbappend b/meta-ibs/meta-common/recipes-bsp/u-boot/libubootenv_%.bbappend
new file mode 100644
index 0000000000..39e097fdd1
--- /dev/null
+++ b/meta-ibs/meta-common/recipes-bsp/u-boot/libubootenv_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
+SRC_URI:append = " file://fw_env.config \
+ file://u-boot-initial-env \
+ "
+
+do_install:append() {
+ install -d ${D}${sysconfdir}
+ install -m 0444 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ install -m 0444 ${WORKDIR}/u-boot-initial-env ${D}${sysconfdir}/u-boot-initial-env
+}