summaryrefslogtreecommitdiff
path: root/meta-ibs/meta-common/recipes-ibs/psu-manager/psu-manager.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibs/meta-common/recipes-ibs/psu-manager/psu-manager.bb')
-rw-r--r--meta-ibs/meta-common/recipes-ibs/psu-manager/psu-manager.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-ibs/meta-common/recipes-ibs/psu-manager/psu-manager.bb b/meta-ibs/meta-common/recipes-ibs/psu-manager/psu-manager.bb
new file mode 100644
index 0000000000..09d670526c
--- /dev/null
+++ b/meta-ibs/meta-common/recipes-ibs/psu-manager/psu-manager.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Power supply manager for Intel based platform"
+DESCRIPTION = "Power supply manager which include PSU Cold Redundancy service"
+
+SRC_URI = "git://git@github.com/Intel-BMC/psu-manager.git;branch=master;protocol=https"
+SRCREV = "5798ef236a83cab2b616321718414fe71d9aacd5"
+
+S = "${WORKDIR}/git"
+
+PV = "1.0+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit cmake
+inherit systemd
+
+SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.coldredundancy.service"
+
+DEPENDS += " \
+ systemd \
+ sdbusplus \
+ phosphor-dbus-interfaces \
+ phosphor-logging \
+ boost \
+ i2c-tools \
+ "