summaryrefslogtreecommitdiff
path: root/meta-ibs/meta-common/recipes-phosphor/interfaces/bmcweb-init-certs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibs/meta-common/recipes-phosphor/interfaces/bmcweb-init-certs.bb')
-rw-r--r--meta-ibs/meta-common/recipes-phosphor/interfaces/bmcweb-init-certs.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-ibs/meta-common/recipes-phosphor/interfaces/bmcweb-init-certs.bb b/meta-ibs/meta-common/recipes-phosphor/interfaces/bmcweb-init-certs.bb
new file mode 100644
index 0000000000..21e411143f
--- /dev/null
+++ b/meta-ibs/meta-common/recipes-phosphor/interfaces/bmcweb-init-certs.bb
@@ -0,0 +1,18 @@
+SUMMARY = "BMCWEB init Certificate"
+DESCRIPTION = "At first BMC boot the BMCWEB service can create expired or invalid certificate. \
+ This script should be run once at first BMC boot to reinstall default PEM-keys \
+ and remove corresponded Logging/Entries."
+
+inherit allarch
+
+RDEPENDS:${PN} = "bash"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBSBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI += "file://bmcweb-init-certs"
+
+do_install:append(){
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/bmcweb-init-certs ${D}${bindir}
+}