summaryrefslogtreecommitdiff
path: root/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm.bb')
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm.bb b/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm.bb
new file mode 100644
index 0000000000..a7fce85394
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Add Dimm interface for inventory manager"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+inherit phosphor-inventory-manager
+
+PROVIDES += "virtual/phosphor-inventory-manager-dimm"
+S = "${WORKDIR}"
+
+SRC_URI = "file://dimm.yaml"
+
+do_install() {
+ install -D dimm.yaml ${D}${base_datadir}/events.d/dimm.yaml
+}
+
+FILES:${PN} += "${base_datadir}/events.d/dimm.yaml"