summaryrefslogtreecommitdiff
path: root/meta-ibs/meta-cp2-5422/recipes-phosphor/webui
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibs/meta-cp2-5422/recipes-phosphor/webui')
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui/config.json9
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui/favicon.icobin0 -> 15406 bytes
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui_%.bbappend13
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/.env.sila11
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0001-Set-login-brand-width.patch36
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/favicon.icobin0 -> 15406 bytes
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/login-company-logo.svg16
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/logo-header.svg16
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend31
9 files changed, 132 insertions, 0 deletions
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui/config.json b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui/config.json
new file mode 100644
index 0000000000..348a7792df
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui/config.json
@@ -0,0 +1,9 @@
+{
+ "customKeyEnable": true,
+ "keyType" : "VT100+",
+ "customConsoleDisplaySize": {
+ "width": 100,
+ "height": 32
+ },
+ "VirtualMediaEnabled" : true
+}
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui/favicon.ico b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui/favicon.ico
new file mode 100644
index 0000000000..c287048077
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui/favicon.ico
Binary files differ
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui_%.bbappend b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui_%.bbappend
new file mode 100644
index 0000000000..1e22d05503
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/phosphor-webui_%.bbappend
@@ -0,0 +1,13 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
+
+SRC_URI += "\
+ file://favicon.ico \
+ "
+
+do_update_logo () {
+ cp ${WORKDIR}/favicon.ico \
+ ${S}/app/assets/images/.
+}
+
+addtask update_logo after do_unpack before do_configure
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/.env.sila b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/.env.sila
new file mode 100644
index 0000000000..52a1cc7b76
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/.env.sila
@@ -0,0 +1,11 @@
+NODE_ENV=production
+VUE_APP_COMPANY_NAME="IBS"
+VUE_APP_GUI_NAME="BMC System Management"
+VUE_APP_SUBSCRIBE_SOCKET_DISABLED="true"
+VUE_APP_SWITCH_TO_BACKUP_IMAGE_DISABLED="true"
+VUE_APP_MODIFY_SSH_POLICY_DISABLED="true"
+VUE_APP_VIRTUAL_MEDIA_LIST_ENABLED="true"
+CUSTOM_STYLES="true"
+CUSTOM_APP_NAV="true"
+CUSTOM_STORE="true"
+CUSTOM_ROUTER="true"
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0001-Set-login-brand-width.patch b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0001-Set-login-brand-width.patch
new file mode 100644
index 0000000000..bdcb8ddc7f
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0001-Set-login-brand-width.patch
@@ -0,0 +1,36 @@
+From 4d8254ef05b5dba035940f3194ef09f1a8770dc9 Mon Sep 17 00:00:00 2001
+From: "Andrey V.Kosteltsev" <AKosteltsev@IBS.RU>
+Date: Wed, 16 Mar 2022 03:55:19 +0300
+Subject: [PATCH] Set login brand width
+
+---
+ src/layouts/LoginLayout.vue | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/layouts/LoginLayout.vue b/src/layouts/LoginLayout.vue
+index cdff204..46939e1 100644
+--- a/src/layouts/LoginLayout.vue
++++ b/src/layouts/LoginLayout.vue
+@@ -5,7 +5,7 @@
+ <div>
+ <div class="login-brand mb-5">
+ <img
+- width="90px"
++ width="60%"
+ src="@/assets/images/login-company-logo.svg"
+ :alt="altLogo"
+ />
+@@ -22,8 +22,8 @@
+ </div>
+ <div class="login-aside__logo-bmc">
+ <img
+- height="60px"
+- src="@/assets/images/built-on-openbmc-logo.svg"
++ height="24px"
++ src="@/assets/images/login-company-logo.svg"
+ alt="Built on OpenBMC"
+ />
+ </div>
+--
+2.33.0
+
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/favicon.ico b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/favicon.ico
new file mode 100644
index 0000000000..1014ebd9c6
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/favicon.ico
Binary files differ
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/login-company-logo.svg b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/login-company-logo.svg
new file mode 100644
index 0000000000..57d11ff43c
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/login-company-logo.svg
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
+<svg
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:xlink="http://www.w3.org/1999/xlink"
+ width="220px" height="50px" viewBox="0 0 89 13"
+ version="1.1">
+ <style type="text/css">
+ .st0{fill:#e11717;}
+ </style>
+ <g id="surface1">
+ <path class="st0" style=" stroke:none;fill-rule:nonzero;fill-opacity:1;" d="M 5.648438 3.261719 C 5.351562 3.253906 5.0625 3.363281 4.847656 3.566406 C 4.628906 3.773438 4.503906 4.054688 4.496094 4.351562 L 4.496094 8.160156 C 4.511719 8.773438 5.019531 9.261719 5.636719 9.246094 L 19.867188 9.246094 L 19.867188 12.960938 L 3.414062 12.960938 C 1.578125 13 0.0625 11.542969 0.0195312 9.710938 C -0.0273438 9.664062 0.0195312 3.28125 0.0195312 3.28125 C 0.0625 1.449219 1.578125 -0.0078125 3.414062 0.03125 L 19.867188 0.03125 L 19.867188 3.261719 Z M 5.648438 3.261719 "/>
+ <path class="st0" style=" stroke:none;fill-rule:nonzero;fill-opacity:1;" d="M 38.398438 0.0390625 L 28.191406 9.738281 L 28.191406 3.199219 L 30.476562 3.195312 L 30.476562 0.0390625 L 23.609375 0.0390625 L 23.609375 12.96875 L 29.929688 12.96875 L 39.78125 3.296875 L 39.78125 12.96875 L 44.269531 12.96875 L 44.269531 0.0390625 Z M 38.398438 0.0390625 "/>
+ <path class="st0" style=" stroke:none;fill-rule:nonzero;fill-opacity:1;" d="M 59.210938 0.0390625 L 50.109375 0.0390625 L 50.109375 3.226562 L 51.542969 3.226562 L 46.457031 12.96875 L 50.761719 12.96875 L 55.828125 3.269531 L 57.519531 3.269531 L 62.582031 12.96875 L 67.132812 12.96875 L 60.347656 0.0390625 Z M 59.210938 0.0390625 "/>
+ <path class="st0" style=" stroke:none;fill-rule:nonzero;fill-opacity:1;" d="M 82.214844 0.0390625 L 72.0625 0.0390625 L 72.0625 3.226562 L 73.410156 3.226562 L 68.34375 12.96875 L 72.648438 12.96875 L 73.46875 11.347656 L 83.597656 11.347656 L 84.441406 12.96875 L 88.996094 12.96875 Z M 75.160156 8.117188 L 77.6875 3.261719 L 79.378906 3.261719 L 81.910156 8.109375 Z M 75.160156 8.117188 "/>
+ </g>
+</svg>
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/logo-header.svg b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/logo-header.svg
new file mode 100644
index 0000000000..60eed5870d
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/logo-header.svg
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
+<svg
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:xlink="http://www.w3.org/1999/xlink"
+ width="90px" height="32px" viewBox="0 0 89 13"
+ version="1.1">
+ <style type="text/css">
+ .st0{fill:#e11717;}
+ </style>
+ <g id="surface1">
+ <path class="st0" style=" stroke:none;fill-rule:nonzero;fill-opacity:1;" d="M 5.648438 3.261719 C 5.351562 3.253906 5.0625 3.363281 4.847656 3.566406 C 4.628906 3.773438 4.503906 4.054688 4.496094 4.351562 L 4.496094 8.160156 C 4.511719 8.773438 5.019531 9.261719 5.636719 9.246094 L 19.867188 9.246094 L 19.867188 12.960938 L 3.414062 12.960938 C 1.578125 13 0.0625 11.542969 0.0195312 9.710938 C -0.0273438 9.664062 0.0195312 3.28125 0.0195312 3.28125 C 0.0625 1.449219 1.578125 -0.0078125 3.414062 0.03125 L 19.867188 0.03125 L 19.867188 3.261719 Z M 5.648438 3.261719 "/>
+ <path class="st0" style=" stroke:none;fill-rule:nonzero;fill-opacity:1;" d="M 38.398438 0.0390625 L 28.191406 9.738281 L 28.191406 3.199219 L 30.476562 3.195312 L 30.476562 0.0390625 L 23.609375 0.0390625 L 23.609375 12.96875 L 29.929688 12.96875 L 39.78125 3.296875 L 39.78125 12.96875 L 44.269531 12.96875 L 44.269531 0.0390625 Z M 38.398438 0.0390625 "/>
+ <path class="st0" style=" stroke:none;fill-rule:nonzero;fill-opacity:1;" d="M 59.210938 0.0390625 L 50.109375 0.0390625 L 50.109375 3.226562 L 51.542969 3.226562 L 46.457031 12.96875 L 50.761719 12.96875 L 55.828125 3.269531 L 57.519531 3.269531 L 62.582031 12.96875 L 67.132812 12.96875 L 60.347656 0.0390625 Z M 59.210938 0.0390625 "/>
+ <path class="st0" style=" stroke:none;fill-rule:nonzero;fill-opacity:1;" d="M 82.214844 0.0390625 L 72.0625 0.0390625 L 72.0625 3.226562 L 73.410156 3.226562 L 68.34375 12.96875 L 72.648438 12.96875 L 73.46875 11.347656 L 83.597656 11.347656 L 84.441406 12.96875 L 88.996094 12.96875 Z M 75.160156 8.117188 L 77.6875 3.261719 L 79.378906 3.261719 L 81.910156 8.109375 Z M 75.160156 8.117188 "/>
+ </g>
+</svg>
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend
new file mode 100644
index 0000000000..a254f3e022
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend
@@ -0,0 +1,31 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
+
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI = "git://git@git.sila.ru/srv/pub/scm/git/openbmc/webui-vue.git;branch=sila;protocol=ssh"
+SRCREV = "35be8fba7201cd69218415fb453e39c13994b0c9"
+
+SRC_URI += "\
+ file://.env.sila \
+ file://favicon.ico \
+ file://login-company-logo.svg \
+ file://logo-header.svg \
+ file://0001-Set-login-brand-width.patch \
+ "
+
+do_update_logo () {
+ cp ${WORKDIR}/.env.sila ${S}/.env
+
+ cp ${WORKDIR}/favicon.ico \
+ ${S}/public/.
+
+ cp ${WORKDIR}/login-company-logo.svg \
+ ${WORKDIR}/logo-header.svg \
+ ${S}/src/assets/images/.
+}
+
+addtask update_logo after do_unpack before do_configure