summaryrefslogtreecommitdiff
path: root/meta-ibs/meta-cp2-5422/recipes-support/smtp/smtp.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibs/meta-cp2-5422/recipes-support/smtp/smtp.bb')
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-support/smtp/smtp.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta-ibs/meta-cp2-5422/recipes-support/smtp/smtp.bb b/meta-ibs/meta-cp2-5422/recipes-support/smtp/smtp.bb
index da02a97905..0e3e72ce9c 100644
--- a/meta-ibs/meta-cp2-5422/recipes-support/smtp/smtp.bb
+++ b/meta-ibs/meta-cp2-5422/recipes-support/smtp/smtp.bb
@@ -8,7 +8,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI = "git://git@git.sila.ru/srv/pub/scm/git/openbmc/obmc-sila-smtp.git;branch=master;protocol=ssh"
-SRCREV = "7e156f58e74baaf4f1d7ccb4df629e6e1a26a32e"
+SRCREV = "629929ebbe386277c25740bc0f4971aac38444d0"
S = "${WORKDIR}/git"
@@ -22,8 +22,12 @@ do_install:append() {
install -m 0744 ${WORKDIR}/mails.txt ${D}/var/lib/smtp/
}
-inherit cmake systemd
+inherit cmake systemd pkgconfig
-DEPENDS = "boost systemd sdbusplus curl"
+DEPENDS = "boost \
+ systemd \
+ sdbusplus \
+ curl \
+ phosphor-logging"
SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.SMTP.service"