summaryrefslogtreecommitdiff
path: root/meta-ibs
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ibs')
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0077-IBS-custom-styles-_tables.scss.patch52
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend6
2 files changed, 36 insertions, 22 deletions
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0077-IBS-custom-styles-_tables.scss.patch b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0077-IBS-custom-styles-_tables.scss.patch
index af5c796b6f..2064b700c1 100644
--- a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0077-IBS-custom-styles-_tables.scss.patch
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0077-IBS-custom-styles-_tables.scss.patch
@@ -1,31 +1,33 @@
-From 49eed9cc3b83eafd9429e7ad5de664c5fa19175e Mon Sep 17 00:00:00 2001
+From 97ef19909e685c062332021acff4c84109669dcb Mon Sep 17 00:00:00 2001
From: "Andrey V.Kosteltsev" <AKosteltsev@IBS.RU>
-Date: Tue, 28 Jun 2022 13:21:48 +0300
+Date: Wed, 29 Jun 2022 23:30:06 +0300
Subject: [PATCH] IBS: custom styles _tables.scss
---
- src/assets/styles/bmc/custom/_tables.scss | 49 +++++++++++++----------
- 1 file changed, 28 insertions(+), 21 deletions(-)
+ src/assets/styles/bmc/custom/_tables.scss | 57 +++++++++++++++--------
+ 1 file changed, 37 insertions(+), 20 deletions(-)
diff --git a/src/assets/styles/bmc/custom/_tables.scss b/src/assets/styles/bmc/custom/_tables.scss
-index e8b5a832..0bccee3a 100644
+index e8b5a832..fd6dfcb7 100644
--- a/src/assets/styles/bmc/custom/_tables.scss
+++ b/src/assets/styles/bmc/custom/_tables.scss
-@@ -3,16 +3,16 @@
+@@ -3,16 +3,18 @@
z-index: $zindex-dropdown;
td {
- border-top: 1px solid gray("300");
- border-bottom: 1px solid gray("300");
+ border-top: 1px solid $gray-10;
-+ border-bottom: 1px solid $gray-10;
++ border-right: 1px solid $gray-10;
++ border-bottom-width: 0px;
&:first-of-type {
- border-left: 1px solid gray("300");
-+ border-left: 1px solid $gray-10;
++ border-right: 1px solid $gray-10;
}
&:last-of-type {
- border-right: 1px solid gray("300");
-+ border-right: 1px solid $gray-10;
++ border-left: 1px solid $gray-10;
++ border-right-width: 0px;
}
vertical-align: middle;
-
@@ -33,7 +35,7 @@ index e8b5a832..0bccee3a 100644
// Table action buttons
.btn-link {
width: 40px;
-@@ -26,19 +26,24 @@
+@@ -26,19 +28,30 @@
// thead-light added for specificity
.thead-light th {
@@ -41,15 +43,17 @@ index e8b5a832..0bccee3a 100644
vertical-align: middle;
- border-top: 1px solid gray("300");
- border-bottom: 1px solid gray("300");
-+ border-top: 1px solid $gray-10;
++ border-top-width: 0px;
+ border-bottom: 1px solid $gray-10;
++ border-right: 1px solid $gray-10;
&:first-of-type {
- border-left: 1px solid gray("300");
-+ border-left: 1px solid $gray-10;
++ border-right: 1px solid $gray-10;
}
&:last-of-type {
- border-right: 1px solid gray("300");
-+ border-right: 1px solid $gray-10;
++ border-left: 1px solid $gray-10;
++ border-right-width: 0px;
}
- color: theme-color("dark");
+ text-transform: uppercase;
@@ -60,14 +64,19 @@ index e8b5a832..0bccee3a 100644
+ & > div {
+ font-size: 0.875rem !important;
+ }
++ }
++
++ .custom-switch {
++ width: 100%;
}
.status-icon svg {
-@@ -56,20 +61,22 @@
+@@ -56,20 +69,23 @@
}
.b-table-details {
- background-color: theme-color("light");
++ border-top: 1px solid rgba(26,62,91,.3);
+ background-color: inherit;
td {
- padding-left: calc(50px + (#{$table-cell-padding} * 2));
@@ -89,7 +98,7 @@ index e8b5a832..0bccee3a 100644
line-height: 1.2
}
}
-@@ -78,7 +85,7 @@
+@@ -78,12 +94,13 @@
width: 50px;
.btn {
padding: 0;
@@ -98,7 +107,13 @@ index e8b5a832..0bccee3a 100644
}
svg {
fill: theme-color("dark");
-@@ -104,12 +111,12 @@
+ }
+ }
++
+ .b-table-sort-icon-left {
+ background-position: left calc(1.5rem / 2) center !important;
+ padding-left: calc(1.2rem + 0.65em) !important;
+@@ -104,12 +121,12 @@
// Table stacked style for small screen only
@include media-breakpoint-down(xs) {
.b-table-stacked-sm {
@@ -107,14 +122,13 @@ index e8b5a832..0bccee3a 100644
tr {
-- &:not(:first-child) > td[aria-colindex='1'] {
+ &:not(:first-child) > td[aria-colindex='1'] {
- border-top: 1px solid gray("300");
-+ &:not(:first-child) > td[aria-colindex='1'] {
+ border-top: 1px solid $gray-10;
padding-top: 0.625rem;
}
-@@ -157,15 +164,15 @@
+@@ -157,15 +174,15 @@
.table.b-table.b-table-stacked-sm > tbody > tr > [data-label] {
&::before {
text-align: left;
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend
index 3fff92a59e..7e77611276 100644
--- a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend
@@ -6,8 +6,10 @@ PV = "1.0+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+EXTRA_OENPM = "-- --mode ibs"
+
SRC_URI = "git://git@git.sila.ru/srv/pub/scm/git/openbmc/webui-vue.git;branch=sila;protocol=ssh"
-SRCREV = "d8970475611ccfe83dd353e8b8b4ddbf43bb1f59"
+SRCREV = "9dc6e1f4baa588f77c866f8d11a62165447e6902"
SRC_URI += "\
file://favicon.ico \
@@ -41,8 +43,6 @@ SRC_URI += "\
"
do_update_logo () {
- mv ${S}/.env.ibs ${S}/.env
-
cp ${WORKDIR}/favicon.ico \
${S}/public/.