summaryrefslogtreecommitdiff
path: root/meta-nuvoton/recipes-nuvoton/program-edid/python3-edid-json-tool_0.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-nuvoton/recipes-nuvoton/program-edid/python3-edid-json-tool_0.9.1.bb')
-rw-r--r--meta-nuvoton/recipes-nuvoton/program-edid/python3-edid-json-tool_0.9.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-nuvoton/recipes-nuvoton/program-edid/python3-edid-json-tool_0.9.1.bb b/meta-nuvoton/recipes-nuvoton/program-edid/python3-edid-json-tool_0.9.1.bb
new file mode 100644
index 0000000000..9bca87514b
--- /dev/null
+++ b/meta-nuvoton/recipes-nuvoton/program-edid/python3-edid-json-tool_0.9.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "EDID to JSON tool"
+DESCRIPTION = "This is a collection of tools that helps you work with \
+EDID files, by parsing them as well as by converting between EDID \
+binaries and JSON files."
+HOMEPAGE = "https://github.com/rpavlik/edid-json-tools"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=dc64d2d7c140d9bd69045b5abaede3a7"
+
+SRC_URI = "git://github.com/rpavlik/edid-json-tools.git;branch=main;protocol=https"
+SRCREV = "1cb9416c10c8186b572fbbc98b51b67c00ec2e70"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+PIP_INSTALL_PACKAGE = "edid-json-tools"
+
+RDEPENDS:${PN} += " \
+ python3-click \
+"
+BBCLASSEXTEND = "native"