summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-filesystems
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-filesystems')
-rw-r--r--meta-openembedded/meta-filesystems/recipes-filesystems/ifuse/ifuse_1.1.4.bb (renamed from meta-openembedded/meta-filesystems/recipes-filesystems/ifuse/ifuse_1.1.2.bb)8
-rw-r--r--meta-openembedded/meta-filesystems/recipes-filesystems/owfs/owfs/0001-Fix-compilation-with-GCC10.patch44
-rw-r--r--meta-openembedded/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb1
-rw-r--r--meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.7.0.bb (renamed from meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb)9
4 files changed, 51 insertions, 11 deletions
diff --git a/meta-openembedded/meta-filesystems/recipes-filesystems/ifuse/ifuse_1.1.2.bb b/meta-openembedded/meta-filesystems/recipes-filesystems/ifuse/ifuse_1.1.4.bb
index f0b58b9673..8a317cddbe 100644
--- a/meta-openembedded/meta-filesystems/recipes-filesystems/ifuse/ifuse_1.1.2.bb
+++ b/meta-openembedded/meta-filesystems/recipes-filesystems/ifuse/ifuse_1.1.4.bb
@@ -5,11 +5,9 @@ HOMEPAGE ="http://www.libimobiledevice.org/"
DEPENDS = "fuse libimobiledevice"
-SRC_URI = " \
- http://www.libimobiledevice.org/downloads/ifuse-${PV}.tar.bz2 \
-"
+SRC_URI = "https://github.com/libimobiledevice/ifuse/releases/download/${PV}/ifuse-${PV}.tar.bz2"
-SRC_URI[md5sum] = "4152526b2ac3c505cb41797d997be14d"
-SRC_URI[sha256sum] = "47835c8afb72588b3202fe0b206d7ea37a68663d9aa4eaf73f0a4bcb6215fc05"
+SRC_URI[md5sum] = "cd31fbd0ea945b2ff1e39eac8d198fdd"
+SRC_URI[sha256sum] = "3550702ef94b2f5f16c7db91c6b3282b2aed1340665834a03e47458e09d98d87"
inherit autotools pkgconfig
diff --git a/meta-openembedded/meta-filesystems/recipes-filesystems/owfs/owfs/0001-Fix-compilation-with-GCC10.patch b/meta-openembedded/meta-filesystems/recipes-filesystems/owfs/owfs/0001-Fix-compilation-with-GCC10.patch
new file mode 100644
index 0000000000..6426ecb247
--- /dev/null
+++ b/meta-openembedded/meta-filesystems/recipes-filesystems/owfs/owfs/0001-Fix-compilation-with-GCC10.patch
@@ -0,0 +1,44 @@
+From a812202d22a2861318b8e39f1cd74cd222f8e76f Mon Sep 17 00:00:00 2001
+From: "Azamat H. Hackimov" <azamat.hackimov@gmail.com>
+Date: Tue, 9 Jun 2020 11:30:38 +0300
+Subject: [PATCH] Fix compilation with GCC10
+
+Fixed compilation with -fno-common, which enabled in GCC 10 by default.
+See https://bugs.gentoo.org/707438.
+
+Upstream-Status: Backport [https://github.com/owfs/owfs/pull/62]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ module/owserver/src/c/owserver.c | 2 ++
+ module/owserver/src/include/owserver.h | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/module/owserver/src/c/owserver.c b/module/owserver/src/c/owserver.c
+index db29988e..2ed29161 100644
+--- a/module/owserver/src/c/owserver.c
++++ b/module/owserver/src/c/owserver.c
+@@ -36,6 +36,8 @@
+
+ #include "owserver.h"
+
++pthread_mutex_t persistence_mutex ;
++
+ /* --- Prototypes ------------ */
+ static void SetupAntiloop(int argc, char **argv);
+
+diff --git a/module/owserver/src/include/owserver.h b/module/owserver/src/include/owserver.h
+index 8be582f0..a257ed02 100644
+--- a/module/owserver/src/include/owserver.h
++++ b/module/owserver/src/include/owserver.h
+@@ -18,7 +18,7 @@
+ #include "ow.h"
+ #include "ow_connection.h"
+
+-pthread_mutex_t persistence_mutex ;
++extern pthread_mutex_t persistence_mutex ;
+ #define PERSISTENCELOCK _MUTEX_LOCK( persistence_mutex ) ;
+ #define PERSISTENCEUNLOCK _MUTEX_UNLOCK( persistence_mutex ) ;
+
+--
+2.28.0
+
diff --git a/meta-openembedded/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb b/meta-openembedded/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb
index 414084449f..7f56c88fcc 100644
--- a/meta-openembedded/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb
+++ b/meta-openembedded/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb
@@ -12,6 +12,7 @@ DEPENDS = "fuse virtual/libusb0"
SRCREV = "3744375dfaa350e31c9b360eb1e1a517bbeb5c47"
SRC_URI = "git://github.com/owfs/owfs \
file://0001-Add-build-rule-for-README.patch \
+ file://0001-Fix-compilation-with-GCC10.patch \
file://owhttpd \
file://owserver \
"
diff --git a/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb b/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.7.0.bb
index 433ce47739..9efcc56174 100644
--- a/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb
+++ b/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.7.0.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://oss.sgi.com/projects/xfs"
SECTION = "base"
LICENSE = "GPLv2 & LGPLv2.1"
LICENSE_libhandle = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038 \
+LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \
file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
DEPENDS = "util-linux util-linux-native"
SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \
@@ -12,9 +12,7 @@ SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \
file://0002-include-include-xfs-linux.h-after-sys-mman.h.patch \
file://0001-support-usrmerge.patch \
"
-SRC_URI[md5sum] = "5ca3f79e76e3fb984a03d1b42a2e60ba"
-SRC_URI[sha256sum] = "7b500e148cebd08f99e37cf744c7843817b37e7be2a32c4dc57d6ea16e3019ae"
-
+SRC_URI[sha256sum] = "8f2348a68a686a3f4491dda5d62dd32d885fbc52d32875edd41e2c296e7b4f35"
inherit autotools-brokensep
PACKAGES =+ "${PN}-fsck ${PN}-mkfs ${PN}-repair libhandle"
@@ -41,9 +39,8 @@ EXTRA_OECONF = "--enable-gettext=no \
DISABLE_STATIC = ""
EXTRA_AUTORECONF += "-I ${S}/m4 --exclude=autoheader"
-PACKAGECONFIG ??= "readline blkid"
+PACKAGECONFIG ??= "blkid"
-PACKAGECONFIG[readline] = "--enable-readline=yes,--enable-readline=no,readline"
PACKAGECONFIG[blkid] = "--enable-blkid=yes,--enable-blkid=no,util-linux"
export DEBUG="-DNDEBUG"