summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-gnome/recipes-gimp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-gnome/recipes-gimp')
-rw-r--r--meta-openembedded/meta-gnome/recipes-gimp/babl/babl_0.1.84.bb (renamed from meta-openembedded/meta-gnome/recipes-gimp/babl/babl_0.1.82.bb)2
-rw-r--r--meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.28.bb (renamed from meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.26.bb)2
-rw-r--r--meta-openembedded/meta-gnome/recipes-gimp/gimp/gimp/0001-configure.ac-fix-with-linux-input-handling-with-upco.patch58
-rw-r--r--meta-openembedded/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb4
-rw-r--r--meta-openembedded/meta-gnome/recipes-gimp/mypaint/libmypaint/0001-make-build-compatible-w.-autoconf-2.7.patch32
-rw-r--r--meta-openembedded/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb4
6 files changed, 98 insertions, 4 deletions
diff --git a/meta-openembedded/meta-gnome/recipes-gimp/babl/babl_0.1.82.bb b/meta-openembedded/meta-gnome/recipes-gimp/babl/babl_0.1.84.bb
index 244b867fae..b49d9d7e8b 100644
--- a/meta-openembedded/meta-gnome/recipes-gimp/babl/babl_0.1.82.bb
+++ b/meta-openembedded/meta-gnome/recipes-gimp/babl/babl_0.1.84.bb
@@ -15,6 +15,6 @@ CFLAGS_append_toolchain-clang_mipsarch = " -ffp-exception-behavior=ignore "
CFLAGS_append_toolchain-clang_riscv64 = " -ffp-exception-behavior=ignore "
SRC_URI = "https://download.gimp.org/pub/${BPN}/0.1/${BP}.tar.xz"
-SRC_URI[sha256sum] = "c62d93d4ad6774cb8e3231bbbc7f2e61e551e7242d78640d757505ee1a9fadc5"
+SRC_URI[sha256sum] = "e7e38b8441f77feb9dc8231cb434a86190a21f2f3692c281457e99d35e9c34ea"
BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.26.bb b/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.28.bb
index 6ac1e6ca96..810036162c 100644
--- a/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.26.bb
+++ b/meta-openembedded/meta-gnome/recipes-gimp/gegl/gegl_0.4.28.bb
@@ -26,7 +26,7 @@ SRC_URI = " \
https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz \
file://0001-meson.build-Give-note-if-sdl2-was-found.patch \
"
-SRC_URI[sha256sum] = "0f371e2ed2b92162fefd3dde743e648ca08a6a1b2b05004867fbddc7e211e424"
+SRC_URI[sha256sum] = "1d110d8577d54cca3b34239315bd37c57ccb27dd4355655074a2d2b3fd897900"
PACKAGECONFIG ??= "gexiv2 jpeg libpng librsvg sdl2"
PACKAGECONFIG_class-native = "libpng librsvg"
diff --git a/meta-openembedded/meta-gnome/recipes-gimp/gimp/gimp/0001-configure.ac-fix-with-linux-input-handling-with-upco.patch b/meta-openembedded/meta-gnome/recipes-gimp/gimp/gimp/0001-configure.ac-fix-with-linux-input-handling-with-upco.patch
new file mode 100644
index 0000000000..7e12487c7b
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gimp/gimp/gimp/0001-configure.ac-fix-with-linux-input-handling-with-upco.patch
@@ -0,0 +1,58 @@
+From 1b66e4cca6d95f4607599bcbdd4afeb601aee84e Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sun, 25 Oct 2020 18:09:21 +0000
+Subject: [PATCH] configure.ac: fix `--with-linux-input` handling with upcoming autoconf-2.70
+
+Upcoming autoconf-2.70 exposes deficiency in configure.ac:
+
+```
+$ autoconf-2.70_beta2 && ./configure --host=x86_64-pc-linux-gnu
+./configure: line 1430: 5: Bad file descriptor
+checking whether is declared... ./configure: line 1432: ${+y}: bad
+```
+
+It happens because macros are called with parameters using insufficient quoting.
+
+More details at https://lists.gnu.org/archive/html/bug-autoconf/2020-10/msg00027.html
+
+The fix only amends `--with-linux-input`. Other cases of underquoting
+will need to be handled separately.
+
+Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gimp/-/commit/cebeb90a87105cd6e35bcb357d53cc04c828ca21]
+Fix-by: Zack Weinberg
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ configure.ac | 17 ++++++++---------
+ 1 file changed, 8 insertions(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6e2c193..afbcdd8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2138,15 +2138,14 @@ fi
+ AC_ARG_WITH(linux-input, [ --without-linux-input don't build linux input event controller module])
+
+ have_linux_input="no (linux input support disabled)"
+-if test "x$with_linux_input" != "xno"; then
+- AC_CHECK_HEADER(linux/input.h,
+- AC_CHECK_DECL(KEY_OK,
+- have_linux_input=yes,
+- have_linux_input="no (needs Linux 2.6)",
+- [#include <linux/input.h>]))
+-fi
+-
+-AM_CONDITIONAL(HAVE_LINUX_INPUT, test "x$have_linux_input" = xyes)
++AS_IF([test "x$with_linux_input" != "xno"],
++ [AC_CHECK_HEADER([linux/input.h],
++ [AC_CHECK_DECL([KEY_OK],
++ [have_linux_input=yes],
++ [have_linux_input="no (needs Linux 2.6)"],
++ [#include <linux/input.h>])])])
++
++AM_CONDITIONAL([HAVE_LINUX_INPUT], [test "x$have_linux_input" = xyes])
+
+
+ ###############################
+--
+2.30.0
+
diff --git a/meta-openembedded/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb b/meta-openembedded/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb
index aec1ebf7b2..070ed1904b 100644
--- a/meta-openembedded/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb
+++ b/meta-openembedded/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb
@@ -37,7 +37,9 @@ REQUIRED_DISTRO_FEATURES = "x11"
SHPV = "${@gnome_verdir("${PV}")}"
-SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2"
+SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2 \
+ file://0001-configure.ac-fix-with-linux-input-handling-with-upco.patch \
+ "
SRC_URI[sha256sum] = "2db84b57f3778d80b3466d7c21a21d22e315c7b062de2883cbaaeda9a0f618bb"
EXTRA_OECONF = "--disable-python \
diff --git a/meta-openembedded/meta-gnome/recipes-gimp/mypaint/libmypaint/0001-make-build-compatible-w.-autoconf-2.7.patch b/meta-openembedded/meta-gnome/recipes-gimp/mypaint/libmypaint/0001-make-build-compatible-w.-autoconf-2.7.patch
new file mode 100644
index 0000000000..28e279438a
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gimp/mypaint/libmypaint/0001-make-build-compatible-w.-autoconf-2.7.patch
@@ -0,0 +1,32 @@
+From 712a101c9aa2eb8548e4d0100a4a2eaf76fad164 Mon Sep 17 00:00:00 2001
+From: Jesper Lloyd <jpl.lloyd@gmail.com>
+Date: Wed, 20 Jan 2021 20:21:53 +0100
+Subject: [PATCH] make build compatible w. autoconf 2.7
+
+Workaround for stricter behaviour (due to a bugfix) in 2.7,
+which makes a failing intltoolize macro check fail the build.
+
+Fix provided by hosiet.
+
+Upstream-Status: Backport [https://github.com/mypaint/libmypaint/commit/a6bac154db018e1f1cc4dbddc34f6c8422c891fb]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 416d9fe..48b9d02 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -248,7 +248,7 @@ if test "x$enable_i18n" != "xno"; then
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE",
+ [The prefix for our gettext translation domains.])
+ AC_SUBST(GETTEXT_PACKAGE)
+- IT_PROG_INTLTOOL
++IT_PROG_INTLTOOL
+ AM_GLIB_GNU_GETTEXT
+
+ dnl Debian: stdlib
+--
+2.30.0
+
diff --git a/meta-openembedded/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb b/meta-openembedded/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb
index 37d41780d2..e711a2a7fa 100644
--- a/meta-openembedded/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb
+++ b/meta-openembedded/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb
@@ -12,7 +12,9 @@ DEPENDS = " \
inherit autotools gobject-introspection gettext python3native
-SRC_URI = "git://github.com/mypaint/libmypaint.git;protocol=https;branch=libmypaint-v1"
+SRC_URI = "git://github.com/mypaint/libmypaint.git;protocol=https;branch=libmypaint-v1 \
+ file://0001-make-build-compatible-w.-autoconf-2.7.patch \
+ "
SRCREV = "2768251dacce3939136c839aeca413f4aa4241d0"
PV = "1.6.1"
S = "${WORKDIR}/git"