summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-gnome/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-gnome/recipes-kernel')
-rw-r--r--meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch63
-rw-r--r--meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch42
-rw-r--r--meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch35
-rw-r--r--meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb37
4 files changed, 0 insertions, 177 deletions
diff --git a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch b/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch
deleted file mode 100644
index 1e2b3c92b4..0000000000
--- a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-libsysprof-ui-Rename-environ-to-sys_environ.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 4bd0d5d5dd6841fbac8385527617d18e7731244d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 15 Jan 2020 13:17:58 -0800
-Subject: [PATCH] libsysprof-ui: Rename environ to sys_environ
-
-This helps avoid namesapace conflict with glibc headers
-
-Fixes
-/usr/include/unistd.h:545:15: note: previous declaration is here
-
-extern char **environ;
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/libsysprof-ui/sysprof-profiler-assistant.c | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/libsysprof-ui/sysprof-profiler-assistant.c b/src/libsysprof-ui/sysprof-profiler-assistant.c
-index 22e3e24..c55d551 100644
---- a/src/libsysprof-ui/sysprof-profiler-assistant.c
-+++ b/src/libsysprof-ui/sysprof-profiler-assistant.c
-@@ -235,7 +235,7 @@ sysprof_profiler_assistant_record_clicked_cb (SysprofProfilerAssistant *self,
- {
- g_auto(GStrv) argv = NULL;
- g_auto(GStrv) env = NULL;
-- SysprofEnviron *environ;
-+ SysprofEnviron *sys_environ;
- const gchar *command;
- gint argc;
-
-@@ -245,8 +245,8 @@ sysprof_profiler_assistant_record_clicked_cb (SysprofProfilerAssistant *self,
- sysprof_profiler_set_spawn (profiler, TRUE);
- sysprof_profiler_set_spawn_argv (profiler, (const gchar * const *)argv);
-
-- environ = sysprof_environ_editor_get_environ (self->environ_editor);
-- env = sysprof_environ_get_environ (environ);
-+ sys_environ = sysprof_environ_editor_get_environ (self->environ_editor);
-+ env = sysprof_environ_get_environ (sys_environ);
- sysprof_profiler_set_spawn_env (profiler, (const gchar * const *)env);
-
- sysprof_profiler_set_spawn_inherit_environ (profiler,
-@@ -405,7 +405,7 @@ sysprof_profiler_assistant_class_init (SysprofProfilerAssistantClass *klass)
- static void
- sysprof_profiler_assistant_init (SysprofProfilerAssistant *self)
- {
-- g_autoptr(SysprofEnviron) environ = sysprof_environ_new ();
-+ g_autoptr(SysprofEnviron) sys_environ = sysprof_environ_new ();
-
- gtk_widget_init_template (GTK_WIDGET (self));
-
-@@ -445,7 +445,7 @@ sysprof_profiler_assistant_init (SysprofProfilerAssistant *self)
- self,
- G_CONNECT_SWAPPED);
-
-- sysprof_environ_editor_set_environ (self->environ_editor, environ);
-+ sysprof_environ_editor_set_environ (self->environ_editor, sys_environ);
- }
-
- void
---
-2.25.0
-
diff --git a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch b/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch
deleted file mode 100644
index 2354892265..0000000000
--- a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 43c39b5685445242d071b3706af2903efa508b4a Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex.kanavin@gmail.com>
-Date: Tue, 14 Jan 2020 12:58:27 +0100
-Subject: [PATCH] meson.build: do not hardcode 'linux' as
- host_machine().system() value
-
-In some build environmets such as OpenEmbedded this can be 'linux-gnueabi'
-or otherwise not exactly 'linux'.
-
-Upstream-Status: Pending
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- src/libsysprof/meson.build | 2 +-
- src/tools/meson.build | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/libsysprof/meson.build b/src/libsysprof/meson.build
-index 3449961..3c2d186 100644
---- a/src/libsysprof/meson.build
-+++ b/src/libsysprof/meson.build
-@@ -84,7 +84,7 @@ libsysprof_deps = [
- polkit_dep,
- ]
-
--if host_machine.system() == 'linux'
-+if host_machine.system().contains('linux')
- libsysprof_public_sources += [
- 'sysprof-memory-source.c',
- 'sysprof-perf-counter.c',
-diff --git a/src/tools/meson.build b/src/tools/meson.build
-index 670052a..3fb7f0c 100644
---- a/src/tools/meson.build
-+++ b/src/tools/meson.build
-@@ -2,7 +2,7 @@ tools_deps = [
- libsysprof_capture_dep,
- ]
-
--if get_option('libsysprof') and host_machine.system() == 'linux'
-+if get_option('libsysprof') and host_machine.system().contains('linux')
- polkit_agent_dep = dependency('polkit-agent-1')
- sysprof_cli = executable('sysprof-cli', 'sysprof-cli.c',
- dependencies: tools_deps + [libsysprof_dep, polkit_dep, polkit_agent_dep],
diff --git a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch b/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch
deleted file mode 100644
index 75aa86cdbf..0000000000
--- a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/files/0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 3025d80aaacc5f67aa9eb1e6fde30f71d9c5b04b Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 18 Jul 2011 16:00:17 -0700
-Subject: [PATCH 1/2] sysprof: Define NT_GNU_BUILD_ID if undefined
-
-On uclibc elf.h does not have GNU extentions but we need this define
-so we define it locally if its not getting it from elf.h
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
-
-%% original patch: define-NT_GNU_BUILD_ID.patch
----
- src/libsysprof/elfparser.h | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/libsysprof/elfparser.h b/src/libsysprof/elfparser.h
-index 160e4c9..94fa5c0 100644
---- a/src/libsysprof/elfparser.h
-+++ b/src/libsysprof/elfparser.h
-@@ -18,6 +18,10 @@
-
- #include <glib.h>
-
-+#ifndef NT_GNU_BUILD_ID
-+#define NT_GNU_BUILD_ID 3
-+#endif
-+
- typedef struct ElfSym ElfSym;
- typedef struct ElfParser ElfParser;
-
---
-2.17.1
-
diff --git a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb b/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
deleted file mode 100644
index ad69ab68c3..0000000000
--- a/meta-openembedded/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-SUMMARY = "System-wide Performance Profiler for Linux"
-HOMEPAGE = "http://www.sysprof.com"
-LICENSE = "GPLv3+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
- file://src/sysprof/sysprof-application.c;endline=17;md5=a3de8df3b0f8876dd01e1388d2d4b607"
-
-GNOMEBASEBUILDCLASS = "meson"
-inherit gnomebase gettext systemd upstream-version-is-even gsettings mime mime-xdg
-
-DEPENDS += "glib-2.0 libxml2-native glib-2.0-native"
-
-SRC_URI[archive.md5sum] = "cc32455277b31afb1965d627ae3e3629"
-SRC_URI[archive.sha256sum] = "844bbb8d8b65071b3bca96f8e921319ceef81f2d2c51fcc9da63a4b355c893d0"
-SRC_URI += "file://0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch \
- file://0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch \
- file://0001-libsysprof-ui-Rename-environ-to-sys_environ.patch \
- "
-
-PACKAGECONFIG ?= "sysprofd libsysprof ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}"
-PACKAGECONFIG[gtk] = "-Denable_gtk=true,-Denable_gtk=false,gtk+3 libdazzle"
-PACKAGECONFIG[sysprofd] = "-Dwith_sysprofd=bundled,-Dwith_sysprofd=none,polkit"
-PACKAGECONFIG[libsysprof] = "-Dlibsysprof=true,-Dlibsysprof=false,polkit"
-
-# Enablig this requries yelp
-EXTRA_OEMESON += "-Dhelp=false -Dsystemdunitdir=${systemd_unitdir}/system"
-
-SOLIBS = ".so"
-FILES_SOLIBSDEV = ""
-
-SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'sysprofd', 'sysprof2.service sysprof3.service', '', d)}"
-
-FILES_${PN} += " \
- ${datadir}/dbus-1/system-services \
- ${datadir}/dbus-1/system.d \
- ${datadir}/dbus-1/interfaces \
- ${datadir}/metainfo \
- "